Riak crashing with {lucene_parse,"syntax error before: "AND""}

Ryan Zezeski rzezeski at basho.com
Mon Nov 7 14:35:27 EST 2011


Hi Spike,

After decoding your msg it looks like your query is simply 'AND'.  The
parser barfs at this as it expects terms on both sides of the AND and this
causes the the listener for that particular connection to go down.  No
other connections should be affected.  Since the query is parsed on the
server there's not a whole lot you can do if a malformed query is sent.  If
these are generated/user input queries then perhaps you could create a
black list (in your application) for common bad queries that come in.
 Also, if your client supports connection pooling that would help too.

-Ryan

On Mon, Nov 7, 2011 at 1:04 PM, Spike Gronim <spike at wavii.com> wrote:

> Hello,
>
> My Riak servers are misbehaving when users enter invalid queries. The
> gen_server erlang process for the PB transport dies but the overall OS
> level process is still alive. I am exclusively using PB to access Riak, so
> everything grinds to a halt. I plan to work around this by writing a Riak
> nanny that verifies that somebody is listening on the PB port every 60s,
> but I think that this is actually a bug in Riak. I have tried to find other
> references to this bug in the mailing list archive and bugzilla but haven't
> found any. If this is really a bug I will write up a more detailed repro in
> bugzilla. Thanks.
>
>
> Crash report: https://gist.github.com/82eaaa8fa8a994999872
>
> Spike Gronim
> spike at wavii.com
>
>
>
>
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20111107/82b025f4/attachment.html>


More information about the riak-users mailing list