riak ubuntu 11 building problems

Ivan Trajkovic ivan.ebiz at gmail.com
Tue Nov 8 21:23:33 EST 2011


I have ubuntu 11.04, not 11.10
could that be an issue

On Tue, Nov 8, 2011 at 8:14 PM, Andrew Musselman <andrew.musselman at gmail.com
> wrote:

>  I can confirm building both erlang and riak from source on Ubuntu 11.10
> works.
>
> That is, everything builds without any complaints or editing config files,
> and then I'm able to add an object to a riak client.
>
> wget http://erlang.org/download/otp_src_R14B03.tar.gz
> tar xzvf otp_src_R14B03.tar.gz
> cd otp_src_R14B03/
> ./configure && make && sudo make install
>
> git clone https://github.com/basho/riak.git
> cd riak/
> git checkout 1.0.1-release
> git fetch
> git pull
> make rel
>
> Thanks all for the advice.
>
> Best
> Andrew
>
>
>
> On 11/08/2011 04:49 PM, Ivan Trajkovic wrote:
>
> yep encountered that issue already and made sure Im using whats supported
> so R14B3, and checking out riak-1.0.1
>
> On Tue, Nov 8, 2011 at 7:17 PM, Jared Morrow <jared at basho.com> wrote:
>
>> When you say you are building from source (github) 1.0.1, are you doing a
>> 'git checkout riak-1.0.1' or building from 'master'?   One note, based on
>> your erts version, you are using a newer erlang than we support.   We have
>> not built or tested Riak against erlang R15.   Try using R14B02 or R14B03
>> for Riak 1.0.1.   If you are building Riak off of master, you can use
>> R14B04 as well.
>>
>>  -Jared
>>
>>  On Tue, Nov 8, 2011 at 3:45 PM, Ivan Trajkovic <ivan.ebiz at gmail.com>wrote:
>>
>>> hi Jared, thank you for your fast response...
>>> interestingly riak 1.0.1 does build now, from source (github)... unlike
>>> before... not really sure what changed.
>>> but the old errors are coming up again, when trying to start riak:
>>>
>>> ~/Desktop/riak/rel/riak$ bin/riak start
>>> escript: Failed to open file:
>>> ~/Desktop/riak/rel/riak/erts-5.9/bin/nodetool
>>> escript: Failed to open file:
>>> ~/Desktop/riak/rel/riak/erts-5.9/bin/nodetool
>>> Error reading ~/Desktop/riak/rel/riak/etc/app.config
>>>
>>>
>>> erts-5.9/bin/nodetool really isnt there
>>> app.config however is present, but Im guessing that error is dependent
>>> on the nodetool failure error coming up
>>>
>>>
>>>
>>  <Thread deleted for size constraints >
>>
>
>
>
> _______________________________________________
> riak-users mailing listriak-users at lists.basho.comhttp://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20111108/9c35060a/attachment.html>


More information about the riak-users mailing list