Nodes neither leaving nor joining the cluster

Nitish Sharma sharmanitishdutt at gmail.com
Wed Nov 9 12:29:05 EST 2011


Hi Alexandre,
Fortunately its a test cluster. Removing the ring files, stopping and
starting the nodes, and then again running *join *brought the cluster in
desirable state.
Name and IP of all the nodes was same all the time, still restarting a
single node brought the whole cluster in inconsistent state. Weird!

Thanks for the tip, though.

Regards
Nitish
On Wed, Nov 9, 2011 at 5:54 PM, Alexandre Ravey
<alexandre.ravey at gmail.com>wrote:

> Hi Nitish,
>
> Did you change the node name or IP at any point?
> If so, you need to reip your node(s).
>
> Run riak-admin status and check the node name in ring_members, must be
> the same as your actual node. (ie, same ip and node name).
> Check also that you are not using xxx at 127.0.0.1 if your nodes aren't
> on the same physical box.
>
> If it's a test cluster you may just rm /var/lib/riak/ring/* (node
> down) and join again.
>
> Regards
>
> Alexandre
>
> On Wed, Nov 9, 2011 at 5:38 PM, Nitish Sharma
> <sharmanitishdutt at gmail.com> wrote:
> > Hi,
> > I've installed riak using pre-compiled Debian binary. I setup a Riak
> cluster
> > consisting of 3 nodes (name of each node in format: riak@<ip_addr>). The
> > configuration file for all the nodes is same.
> > Just to clarify my problem, I'll be using node names as A, B, and C.
> > Initially, all three nodes were successfully able to form a cluster ( B
> and
> > C joined node A). To perform some tests, node A rebooted and after that
> its
> > ``status" is not showing all three nodes as ring_members. While, running
> > ``riak-admin status" on nodes B and C was still stating ring_members as
> A,
> > B, C.
> > Running ``riak-admin leave" on nodes B and C didnt help, since
> > running join command again was throwing "Failed: This node is already a
> > member of a cluster". Force removal of nodes also didnt do any good;
> still
> > the same inconsistent ring members status.
> > Any suggestions ?
> > Regards
> > Nitish
> >
> > _______________________________________________
> > riak-users mailing list
> > riak-users at lists.basho.com
> > http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
> >
> >
>
t
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20111109/c33ceb75/attachment.html>


More information about the riak-users mailing list