Riak Installation issue on Mac

Geeth Narayanan gnarayan1 at gmail.com
Wed Nov 9 21:27:18 EST 2011


Thanks Jeremiah.
Here are the results of running those commands:

$ gcc -version
i686-apple-darwin10-gcc-4.2.1: no input files

$ ls /Developer/usr/lib/gcc
i686-apple-darwin10 powerpc-apple-darwin10

-Geeth

On Wed, Nov 9, 2011 at 3:24 PM, Jeremiah Peschka <jeremiah.peschka at gmail.com
> wrote:

> In Terminal, what do the following commands produce as output:
>
> gcc --version
>
> ls /Developer/usr/lib/gcc/
>
> The errors you're seeing in the file you attached specifically indicate
> that you do not have a properly working set of tools to build software
> C/C++ programs.
>
>
> ---
> Jeremiah Peschka - Founder, Brent Ozar PLF, LLC
> Microsoft SQL Server MVP
>
> On Nov 9, 2011, at 1:03 PM, Geeth Narayanan wrote:
>
> > Jeff/Alexander,
> >
> > Thanks for your replies. I do have both Xcode and Erlang installed.
> >
> > $  ls /Developer
> > About Xcode and iOS SDK.pdf   Extras                          Platforms
> > About Xcode.pdf                       Headers
> SDKs
> > Applications                  Icon?                           Tools
> > Documentation                 Library                         usr
> > Examples                      Makefiles
> >
> > $ erl
> > Erlang R14B03 (erts-5.8.4) [source] [smp:4:4] [rq:4] [async-threads:0]
> [hipe] [kernel-poll:false]
> >
> > Eshell V5.8.4  (abort with ^G)
> > 1>
> >
> > Is there anything you want me to specifically check?
> >
> > Thanks.
> > Geeth
> >
> >
> >
> > On Wed, Nov 9, 2011 at 2:23 PM, Jeff Kirkell <jeff.kirkell at gmail.com>
> wrote:
> > You need Xcode git and erlang to compile on Mac
> >
> > Sent from my iPhone
> >
> > On Nov 9, 2011, at 3:22 PM, Alexander Sicular <siculars at gmail.com>
> wrote:
> >
> >> Think you need Xcode installed to compile.
> >> @siculars
> >> http://siculars.posterous.com
> >>
> >> Sent from my rotary phone.
> >>
> >> On Nov 9, 2011 3:00 PM, "Geeth Narayanan" <gnarayan1 at gmail.com> wrote:
> >> Hi,
> >>
> >> I am trying to install Riak on my Mac OS X and cloned the source from
> git repo. When I tried to make, I am getting an error. Could you please let
> me know what the issue is and how I can solve it? I have attached the info
> in the shell.
> >>
> >> Thanks.
> >> Geeth
> >>
> >> _______________________________________________
> >> riak-users mailing list
> >> riak-users at lists.basho.com
> >> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
> >>
> >> _______________________________________________
> >> riak-users mailing list
> >> riak-users at lists.basho.com
> >> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
> >
> > _______________________________________________
> > riak-users mailing list
> > riak-users at lists.basho.com
> > http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20111109/36baf8de/attachment.html>


More information about the riak-users mailing list