riak build process erlang version detection

Kelly McLaughlin mclaughlin77 at gmail.com
Fri Nov 11 12:26:01 EST 2011


Ivan,

The erlang version is checked in the rebar.config file. You should see a line like this: {require_otp_vsn, "R14B0[23]"}. 

It's strange that you end up with 2 differents erts folders in your rel directory. I would suggest wiping out the rel/riak directory and rebuilding. If you're still getting issues then it sounds like just a path problem so try to verify your environment and maybe just remove the R15A installation altogether. Hope that helps.

Kelly

On Nov 10, 2011, at 12:49 AM, Ivan Trajkovic wrote:

> can anyone point me to section in the build files for riak where the erlang version is being checked for?
> 
> when I build riak on my current system in my rel/riak folder both the erts-5.9 and erts-5.8.4 folders are created, and riak is having trouble starting after that. 
> the issue is that some weeks ago I build erlang R15A and installed it globally on my Ubuntu 11.04. after that I rebuild R14B03 and installed that globaly, but now Im guessing that R15A left some mark someplace thats being still detected by riaks build scripts, hence the creation/usage of the erts-5.9 folder... 
> 
> on a prestene Ubuntu 11.10 linode server where I built/installed R14B03 from the start (no R15A), only the erts-5.8.4 is created, and riak works fine and passes its own tests. 
> 
> 
> 
> thank you
> 
> 
> ps. this is in connection to my previous thread about having trouble building riak on Ubuntu 11.04
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com





More information about the riak-users mailing list