Can't start second node in local machine

Jeff Kirkell jeff.kirkell at gmail.com
Fri Nov 18 23:05:54 EST 2011


You need to change the ports as well. If you built using the github source,
it would make you 4 nodes each configured with a separate port, otherwise
you need to manually need to change them on the second node.

The limit warning is separate and will not cause issues if you are playing
around. If you want to get rid of it, there is a tutorial on the Basho wiki
on how to set the limit in OS X.

Hope that helps,
Jeff

On Fri, Nov 18, 2011 at 10:24 PM, yozloy <yozloy at me.com> wrote:

> I copied the riak-1.0.2 folder, and change the node name to
> riak2 at 127.0.0.1 in the vm.args file. But the changed node refused to
> start, it returned
>
> Argo:bin yozloy$ ./riak start
> !!!!
> !!!! WARNING: ulimit -n is 256; 1024 is the recommended minimum.
> !!!!
> Riak failed to start within 15 seconds,
> see the output of 'riak console' for more information.
> If you want to wait longer, set the environment variable
> WAIT_FOR_ERLANG to the number of seconds to wait.
> Argo:bin yozloy$ ls
>
>
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20111118/73b45edf/attachment.html>


More information about the riak-users mailing list