map/reduce fails after riak upgrade

Lyes zaiko lyesjob at gmail.com
Mon Nov 28 10:36:59 EST 2011


Finally it was my fault, I've forgotten to upgrade my client node to
riak-1.0.2


On Mon, Nov 28, 2011 at 2:31 PM, Lyes zaiko <lyesjob at gmail.com> wrote:

> Ok, I will give it a try
>
>
> On Mon, Nov 28, 2011 at 1:50 PM, Leonid Riaboshtan <
> perfecthumanorama at gmail.com> wrote:
>
>> Hello,
>>
>> Try to use legacy mapred mode instead of pipe one(it's default in new
>> riak versions)? Maybe it's a finger into sky, but still may hit it :)
>>
>> WBR,
>> Leonid
>>
>> On Mon, Nov 28, 2011 at 12:28 PM, Lyes zaiko <lyesjob at gmail.com> wrote:
>>
>>> Hi!
>>>
>>> I upgraded to riak-1.0.2.
>>> I'm using the erlang client to execute a map/reduce on a bucket. In the
>>> anterior version of riak I was using, this map/reduce was working very
>>> well. But after the upgrade, it takes much time to end. When I attached the
>>> riak node,  I git this errir
>>>
>>> {undef,[{riak_kv_keys_fsm,start,[125220437,{<<20
>>> bytes>>,[]},60000,mapred,3.000000e-05,<0.409.0>]}]}
>>>
>>> what changed in the erlang client map/reduce call ??
>>>
>>> PS: I'm using riak_pb_socket:mapred_bucket().
>>>
>>> _______________________________________________
>>> riak-users mailing list
>>> riak-users at lists.basho.com
>>> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>>>
>>>
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20111128/f70db4f1/attachment.html>


More information about the riak-users mailing list