Question: {error,{error,insufficient_vnodes_available}}

Chung-Hung (Walter) Tsai waltertsai at gmail.com
Mon Nov 28 18:06:47 EST 2011


Hi Dan,

Yes, I use non-default name parameter and reip it.

Please find my setting and setup info as below:

Version: 1.0.2, .deb
Linux: Unbuntu 10.4, 64bits
Vnode: I didn't specify the other 2 nodes specifically, just used
default setting and did riak start.
The DB has a bumping due to insufficient file descriptor and got
resolved after I set ulimit and sysctl for system-wide parameters.
It ran ok for several days but since yesterday, it gave us the error
message regarding insufficient vnodes errors.

I'm trying to setup 2 additional nodes by copying and modding
necessary files (e.g. /usr/sbin/riak to /usr/sbin/riakN) manually now.
But they each become a single cluster with just a single member in it
and doesn't allow other vnodes to join.
When I launch "riak-admin", it shows something like " ... 100% ...
riak at MY-IP-ADDRESS"


Thanks,
Walter

2011/11/29 Dan Reverri <dan at basho.com>:
> Hi Walter,
> Have you made any changes to your configuration recently such as changing
> the "-name" parameter in vm.args?
> Thanks,
> Dan
> Daniel Reverri
> Developer Advocate
> Basho Technologies, Inc.
> dan at basho.com
>
>
> On Mon, Nov 28, 2011 at 1:04 AM, Chung-Hung (Walter) Tsai
> <waltertsai at gmail.com> wrote:
>>
>> Hello everyone,
>>
>> We just saw many errors like this:
>>
>> 2011-11-27 23:02:01.129 [error] <0.700.0> webmachine error:
>> path="/buckets/.. (SKIPPED).....ui"
>> {error,{error,insufficient_vnodes_available}}
>>
>> The DB went well for several days, but now our riak cannot be
>> connected from our code since the errors appear.
>> Does anyone know how to resolve the issue?
>>
>>
>> Thanks,
>> Walter
>>
>> _______________________________________________
>> riak-users mailing list
>> riak-users at lists.basho.com
>> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>
>




More information about the riak-users mailing list