Nodes not leaving in Riak 0.14.2

Anthony Molinaro anthonym at alumni.caltech.edu
Mon Apr 2 21:28:00 EDT 2012


Hi,

  So I found one of my riak clusters misbehaving and found out it was
running on some inferior hardware.  After getting some new machines from
my ops group.  I went ahead and added several nodes.  Everything went
relatively smoothly until I tried to have the old nodes leave the ring.

I need to remove 4 nodes, and I assumed since I had been successful
adding a few nodes at once, I would also be able to have multiple nodes
leave.

Unfortunately, that does not appear to be the case.  One node (the first
removed) completely left, the others did not.  Then no matter how many
times I did a 'riak-admin leave' they would not leave.  I re-added the
one that had left successfully to see if a ring change would unstick
something.  It does appear to, as even with all the original nodes back
the 3 I attempted to have leave are still not leaving.

I'm going through now and just doing a rolling restart hoping that
might fix things, but I'm thinking I might be stuck.

Is there anyway to remove these nodes?

Thanks,

-Anthony

-- 
------------------------------------------------------------------------
Anthony Molinaro                           <anthonym at alumni.caltech.edu>




More information about the riak-users mailing list