Node riak at 192.168.56.101 is not reachable!

Antonio Ye antonioye at gmail.com
Thu Apr 5 01:46:34 EDT 2012


Thanks for the reply. It turns out I had the firewall turned on. After I
disabled it following these instructions, I was able to join the two nodes.

http://www.cyberciti.biz/faq/disable-linux-firewall-under-centos-rhel-fedora/

Thanks,
Tony

On Wed, Apr 4, 2012 at 10:20 PM, Daniel Reverri <dan at basho.com> wrote:

> Hi Antonio,
>
> Can you check the output of `riak-admin status` on both machines?
> Specifically, what are the values of `nodename` and `ring_members`?
>
> Also, can you share the vm.args files from both machines?
>
> Thanks,
> Dan
>
> --
> Daniel Reverri
> Developer Advocate
> Basho Technologies, Inc.
> dan at basho.com
>
>
> On Wednesday, April 4, 2012 at 8:20 PM, Antonio Ye wrote:
>
> > I have been struggling with this problem for the last the days. I have
> setup two VMs using VirtualBox running centos and installed riak 1.1.1-1
> rpm. I have changed the 127.0.0.1 to the actual IP in the app.config and
> have changed the name in the vm.args on each of the VMs. I can ping,
> telnet, ssh from one machine to the other but no matter what I do I keep
> getting the not reachable error when I type 'riak-admin join
> riak at 192.168.56.101 (mailto:riak at 192.168.56.101)'. I have read and tried
> everything described in a thread talking about this problem in a EC2
> cluster but nothing I do seems to work. Anyone have any ideas?
> >
> > Thanks!
> > _______________________________________________
> > riak-users mailing list
> > riak-users at lists.basho.com (mailto:riak-users at lists.basho.com)
> > http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20120404/5c9480cd/attachment.html>


More information about the riak-users mailing list