Turn off Riak Control authentication completely?

Jeffrey Massung jeff at basho.com
Tue Apr 17 10:33:03 EDT 2012


Nathaniel,

I'll have to go through the commit log, but I'm fairly confident that this bug was fixed. I just tried it and am not prompted with the password. If you do a `git log` in deps/riak_control, what's the latest commit SHA that you have?

Also, when you use 'none' as the authentication method, there's no need to use HTTPS. So, give going to http://ip.com:8098/admin and see if that works for you without authenticating (note: SSL should still work as well and not ask for credentials).

I'll take a look at the code again, though. Let me know if HTTP doesn't work for you as it should.

- jeff

On Apr 16, 2012, at 7:48 PM, Nathaniel Talbott wrote:

> We're running Riak Control within a controlled VPN environment, so
> we'd like to turn off basic auth completely. However, when we set auth
> to "none", we still get prompted for basic auth, the only difference
> is any old username and password will work. Is there any way to turn
> off the prompt completely? We're on 1.1.1 (just upgraded - woot!)
> 
> Thanks,
> 
> 
> --
> Nathaniel
> 
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20120417/87faeacc/attachment.html>


More information about the riak-users mailing list