Issue with Riak Install from Source under SUSE SLES 11 SP11 Version S390

Jared Morrow jared at basho.com
Sat Apr 28 00:17:11 EDT 2012


Claude,

The issue is not in the rebar.config file for eleveldb, but in a file that fetches the original C++ source for leveldb.   To fix your issue, simply unpack the riak source as you already did then:

$ cd deps/eleveldb

And then make the following changes to 'c_src/build_deps.sh':

--- c_src/build_deps.sh.orig	2012-04-27 22:06:31.000000000 -0600
+++ c_src/build_deps.sh	2012-04-27 22:07:49.000000000 -0600
@@ -37,7 +37,7 @@
         export LD_LIBRARY_PATH="$BASEDIR/system/lib:$LD_LIBRARY_PATH"
 
         if [ ! -d leveldb ]; then
-            git clone git://github.com/basho/leveldb
+            git clone http://github.com/basho/leveldb
             (cd leveldb && git checkout $LEVELDB_VSN)
         fi
 
Then return to the top-level source directory for Riak and run 'make' and things should be better.

-Jared




On Apr 27, 2012, at 12:31 PM, claudef at br.ibm.com wrote:

> Dear colleagues, 
> 
> Trying to install the RIAK package under a  SUSE SLES 11 SP11 Version S390. I've downloaded the .tar.gz install file from the BASHO site. First I've installed the Erlang package with the --with-ssl option and recompiled the openssl package with the "shared" option, as requested by the Erlang procedure. 
> 
> Using the "make rel" command, I see a successful build running on the screen, until a point where the install tries to connect to the GITHUB, throwing an error like this: 
>     
> test -z "/opt/riak/riak-1.1.2/deps/eleveldb/c_src/system/share/doc/snappy" || /bin/mkdir -p "/opt/riak/riak-1.1.2/deps/eleveldb/c_src/system/share/doc/snappy" 
>  /usr/bin/install -c -m 644 ChangeLog COPYING INSTALL NEWS README format_description.txt '/opt/riak/riak-1.1.2/deps/eleveldb/c_src/system/share/doc/snappy' 
> test -z "/opt/riak/riak-1.1.2/deps/eleveldb/c_src/system/include" || /bin/mkdir -p "/opt/riak/riak-1.1.2/deps/eleveldb/c_src/system/include" 
>  /usr/bin/install -c -m 644 snappy.h snappy-sinksource.h snappy-stubs-public.h snappy-c.h '/opt/riak/riak-1.1.2/deps/eleveldb/c_src/system/include' 
> make[2]: Leaving directory `/opt/riak/riak-1.1.2/deps/eleveldb/c_src/snappy-1.0.4' 
> make[1]: Leaving directory `/opt/riak/riak-1.1.2/deps/eleveldb/c_src/snappy-1.0.4' 
> 
> fatal: unable to connect to github.com: 
> github.com[0: 207.97.227.239]: errno=Connection refused 
> 
> Cloning into 'leveldb'... 
> ERROR: Command [compile] failed! 
> make: *** [rel] Error 1 
>   
> The riak executable was not yet created under the /bin. 
> 
> 
> Question:   
> -------------- 
> Is there a way to avoid a connect to GITHUB during the package build from source, or could you give me a pointer what is causing the connection to be refused, as our firewall is configured for outgoing HTTP connections (which port and protocol does it use?). 
> 
> Thanks in advance for your feedback and support. 
> 
> Regards, 
> Claude   
> 
> 
> 
> Claude Falbriard 
> Certified IT Specialist L2 - Middleware
> AMS Hortolândia / SP - Brazil
> phone:    +55 19 9837 0789
> cell:         +55 13 8117 3316
> e-mail:    claudef at br.ibm.com
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20120427/64ef0cc0/attachment.html>


More information about the riak-users mailing list