riak-admin status & /stats very slow

Sebastian Cohnen sebastian.cohnen at gmail.com
Fri Aug 3 19:38:32 EDT 2012


I still get this error with the latest 1.2 rc6 (1.2.0rc6-osx-i386).

On 29.07.2012, at 13:56, Sebastian Cohnen <sebastian.cohnen at gmail.com> wrote:

> Hey list,
> 
> I just noticed that riak-admin status is very slow on my local machine and contains "{error,timeout}" for cpu_* fields. To verify that my homebrew installation isn't messed up, I downloaded riak-1.1.4 for OS X in 32 and 64 bit and started riak from there without changing anything in the config files. Everything seems to work fine (e.g. riak-admin test) and the node seems to be accessible.
> 
> riak-admin status however takes up to 50-60sec to complete (see [0] for its output), and the http://localhost:8098/stats times out every single time (also see [0]). The logs (and also the riak-admin status output) indicate that there is a problem reading the CPU usage, see [1].
> 
> I'm on OS X (10.8), MacBook Pro Retina (MacBookPro10,1), 16GB RAM and, as I said, riak 1.1.4. As far as I can tell, I get the same error from the 32 and 64bit version.
> 
> 
> 
> Best
> 
> Sebastian
> 
> 
> [0] https://gist.github.com/3197626
> 
> [1] crash.log
> 
> 2012-07-29 13:12:39 =ERROR REPORT====
> Error in process <0.3246.0> on node 'riak at 127.0.0.1' with exit value: {{badmatch,{error,{fread,float}}},[{cpu_sup,get_uint32_measurement,2},{cpu_sup,measurement_server_loop,1}]}
> 
> console.log
> 
> 2012-07-29 13:12:59.068 [error] <0.1748.0> webmachine error: path="/stats"
> {error,{exit,{json_encode,{bad_term,{error,timeout}}},[{mochijson2,json_encode,2},{mochijson2,'-json_encode_proplist/2-fun-0-',3},{lists,foldl,3},{mochijson2,json_encode_proplist,2},{riak_kv_wm_stats,produce_body,2},{webmachine_resource,resource_call,3},{webmachine_resource,do,3},{webmachine_decision_core,resource_call,1}]}}





More information about the riak-users mailing list