OS X Source Compile Woes

Christopher Meiklejohn cmeiklejohn at basho.com
Tue Aug 7 22:19:05 EDT 2012


Sweet, glad to hear it!


On Tuesday, August 7, 2012 at 10:16 PM, Jeff Kirkell wrote:

> Chris,
> 
> That did it. I did have to completely remove Erlang and reinstall but it now works.
> 
> Thanks.
> 
> On Tue, Aug 7, 2012 at 9:37 PM, Kelly McLaughlin <kelly at basho.com (mailto:kelly at basho.com)> wrote:
> > Jeff,
> > 
> > Have you installed the Xcode command line tools and made sure all older Xcode versions have been removed?
> > 
> > If so try this:
> > 
> >     sudo ln -s /Applications/Xcode.app/Contents/Developer /Developer
> > 
> > 
> > 
> > Sent from my iPhone
> > 
> > On Aug 7, 2012, at 7:28 PM, Jeff Kirkell <jeff.kirkell at gmail.com (mailto:jeff.kirkell at gmail.com)> wrote:
> > 
> > > Is anyone having trouble compiling from github source on OS X Mountain Lion? I am currently running Erlang R15B01.
> > >
> > > Not sure if there is an official log file, but here is what appears prior to the compile error
> > >
> > > in16.h ../../dist/include/nspr
> > > cd src; make export
> > > cd io; make export
> > > make[6]: Nothing to be done for `export'.
> > > cd linking; make export
> > > cc -o prlink.o -c     -m32  -Wall -fno-common -pthread -O2 -fPIC  -UDEBUG  -DNDEBUG=1 -DXP_UNIX=1 -DDARWIN=1 -DHAVE_BSD_FLOCK=1 -DHAVE_SOCKLEN_T=1 -DXP_MACOSX=1 -DHAVE_LCHOWN=1 -DHAVE_STRERROR=1  -DFORCE_PR_LOG -D_PR_PTHREADS -UHAVE_CVAR_BUILT_ON_SEM -D_NSPR_BUILD_ -I../../../dist/include/nspr -I../../../pr/include -I../../../pr/include/private -I/Developer/Headers/FlatCarbon  prlink.c
> > > prlink.c:48:10: fatal error: 'CodeFragments.h' file not found
> > > #include <CodeFragments.h>
> > >          ^
> > > 1 error generated.
> > > make[6]: *** [prlink.o] Error 1
> > > make[5]: *** [export] Error 2
> > > make[4]: *** [export] Error 2
> > > make[3]: *** [export] Error 2
> > > make[2]: *** [/Users/jeff/Database/riaka-1.2.0/deps/erlang_js/c_src/system/lib/libnspr4.a] Error 2
> > > make[1]: *** [c_src] Error 2
> > > ERROR: Command [compile] failed!
> > > make: *** [rel] Error 1
> > >
> > > P.S. this happens when doing make or any of the sub-commands i.e. make rel
> > >
> > > Thanks.
> > > Jeff
> > > _______________________________________________
> > > riak-users mailing list
> > > riak-users at lists.basho.com (mailto:riak-users at lists.basho.com)
> > > http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
> 
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com (mailto:riak-users at lists.basho.com)
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
> 
> 


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20120807/d9df8579/attachment.html>


More information about the riak-users mailing list