Requesting Installation Help

Zabrane Mickael zabrane3 at gmail.com
Sat Jun 9 02:55:51 EDT 2012


Hi Trevor,

We've teh latest Riak up and running on Fedora 17 with R15B01.

Follow these are the steps:

$ wget http://downloads.basho.com.s3-website-us-east-1.amazonaws.com/riak/CURRENT/riak-1.1.2.tar.gz
$ tar xzvf riak-1.1.2.tar.gz
$ cd riak-1.1.2
$ ./rebar get-deps

Remove this line "{require_otp_vsn, "R14B0[234]|R15"}." from all these files:
$ find . -name "rebar.config" | xargs grep "require_otp_vsn"

./deps/cluster_info/rebar.config:{require_otp_vsn, "R13B04|R14"}.
./deps/riak_kv/rebar.config:{require_otp_vsn, "R13B04|R14"}.
./deps/riak_search/rebar.config:{require_otp_vsn, "R13B04|R14"}.
./rebar.config:{require_otp_vsn, "R14B0[234]"}.

Build a RIAK release:
$ yum -y groupinstall "Development Tools"
$ make rel

When done:
$ su
# mv rel/riak   /opt/riak

Then, try it:
cd /opt/riak
./bin/riak console

Good luck.

Regards,
Zabrane


On Jun 9, 2012, at 8:38 AM, Jared Morrow wrote:

> Trevor,
> 
> I don't have a FC 17 VM handy, so I can't test it, but have you tried the FC 15 package from http://basho.com/resources/downloads/?   The only problem I could see you having is a wrong dependency on openssl, but you should be able to install the matching one along side the one that installs with FC 17.
> 
> The proper erlang is bundled in the Riak packages, so you won't need Erlang installed otherwise.  Let me know either way if it works.
> 
> -Jared
> 
> 
> On Jun 8, 2012, at 9:08 PM, Trevor Hunsaker wrote:
> 
>> I'm having troubles getting riak installed on Fedora 17.  First, I tried with the packaged Erlang (R15B01). make rel complained about my Erlang version.  It didn't work to changing the version regex everywhere I could find, though it's possible I missed some. Then, I built R14B03, and I get an "Uncaught error in rebar_core" error during make rel:
>> 
>> [trevor at fox riak-1.1.2]$ make rel> 
>> fatal: Not a git repository (or any parent up to mount point /home)
>> Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set).
>> ./rebar get-deps
>> ==> cluster_info (get-deps)
>> Uncaught error in rebar_core: {'EXIT',
>>                                {function_clause,
>>                                 [{lists,thing_to_list,
>>                                   [{error,bad_name}],
>>                                   [{file,"lists.erl"},{line,537}]},
>>                                  {lists,flatmap,2,
>>                                   [{file,"lists.erl"},{line,1184}]},
>>                                  {lists,flatmap,2,
>>                                   [{file,"lists.erl"},{line,1184}]},
>>                                  {rebar_port_compiler,default_env,0,[]},
>>                                  {rebar_port_compiler,setup_env,1,[]},
>>                                  {rebar_core,'-setup_envs/2-lc$^0/1-0-',2,[]},
>>                                  {rebar_core,'-setup_envs/2-lc$^0/1-0-',2,[]},
>>                                  {rebar_core,setup_envs,2,[]}]}}
>> make: *** [deps] Error 1
>> 
>> I'm not sure what to try next and could use any suggestion.
>> 
>> Trevor 
>> _______________________________________________
>> riak-users mailing list
>> riak-users at lists.basho.com
>> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
> 
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20120609/f99792c9/attachment.html>


More information about the riak-users mailing list