devrel remote ip help

Marv Lush marv_lush at yahoo.com
Tue Jun 12 19:31:00 EDT 2012


Austin,

Shouldn't need to reip since I modified the configs before starting nodes for the first time.

However...you bring up a point I totally forgot..the security group config. Duh...that's probably it. Feel like an idiot for not remembering that.

thanks,
/m

--- On Tue, 6/12/12, Swinney, Austin <Austin at vimeo.com> wrote:

> From: Swinney, Austin <Austin at vimeo.com>
> Subject: Re: devrel remote ip help
> To: "Marv Lush" <marv_lush at yahoo.com>
> Cc: "<riak-users at lists.basho.com>" <riak-users at lists.basho.com>
> Date: Tuesday, June 12, 2012, 1:00 PM
> Hi Marv,
> 
> I don't recall having your problem specifically, but if it
> happened to me, I would ask myself:
> 
> * did you reip your node using `riak-admin reip`?
> 
> * on ec2, is your security group configured to allow inbound
> and outbound traffic within the security group?
> 
> Also, by 'hangs' I guess you mean you never got to the wait
> complete message in /var/log/riak/console.log :
> 
> 2012-06-12 15:58:58.199 [info]
> <0.18466.349>@riak_core:wait_for_service:416 Waiting
> for service riak_kv to start (0 seconds)
> 2012-06-12 15:58:58.296 [info]
> <0.18460.349>@riak_core:wait_for_application:390 Wait
> complete for application riak_kv (0 seconds)
> 
> 
> 
> 
> On Jun 12, 2012, at 3:09 PM, Marv Lush wrote:
> 
> > Tried setting up a riak 4 node dev cluster on an EC2
> box today per the instructions.
> > 
> > Seems to work fine for any requests to 127.0.0.1
> However, when I try to remote in (from my desktop to the EC2
> box)...I get no response.
> > 
> > I assume this is because I need to configure app.config
> and vm.args with something like:
> > 
> > {http, [ {"<remote.ip>", <some.port> } ]},
> > 
> > -name devN@<remote.ip>
> > 
> > 
> > respectively....instead of 127.0.0.1. However, when I
> made modifications to the required files...by using my EC2
> box's elastic IP, and I try to start...it just sits there
> and hangs...
> > 
> > Is there some secret sauce needed to get the dev
> environment working with remote IP's?
> > 
> > thanks.
> > 
> > /m
> > 
> > _______________________________________________
> > riak-users mailing list
> > riak-users at lists.basho.com
> > http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
> 
> 




More information about the riak-users mailing list