riak newbie

Brian Roach roach at basho.com
Thu Jun 21 09:37:02 EDT 2012


Hi Anand,

The brew install actually gives you compiled code, and no makefile. In addition, the startup scripts are slightly different that when installing from source.

I recently answered the same question on StackOverflow which should point you in the right direction:
http://stackoverflow.com/questions/9906386/running-a-three-node-riak-cluster-using-a-homebrew-installation

Basically, you need to manually make copies of the /usr/local/Cellar/riak directory and edit the files accordingly, including the startup scripts themselves. 

Please let us know if you have additional questions!

Thanks,
Brian Roach


On Jun 21, 2012, at 7:21 AM, Anand Hegde wrote:

> I am trying to get the 4 node setup working on my os x lion machine.
> 
> sorry If you are getting this a second time but I think my first mail got lost because I was a non member.
> 
> I installed riak using 
> 
> $ brew install riak
> 
> I am using the online documentation available - http://wiki.basho.com/Building-a-Development-Environment.html
> 
> I am stuck on this step - "Use rebar to start up four nodes. "
> 
> After installing riak, do I have to install rebar as well? After installing riak I directly tried the 
> 
> $ make devrel 
> 
> command and it gave the following error  
> 
> make: *** No rule to make target `devrel'.  Stop.
> 
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com





More information about the riak-users mailing list