Cannot Install Riak

Nick Tune nick.tune at 7digital.com
Thu Jun 21 14:13:19 EDT 2012


Ok it is definitely one of those days. I've come home and tried to install
on my home pc. And now I get this error:

Compiled src/etop_txt.erl
==> rel (generate)
ERROR: Unable to generate spec: read file info
/usr/lib/erlang/man/man1/precat.1 failed
make: *** [rel] Error 1

Thanks for all your help. I think I'll just come back to riak another day
once my mind is cleared of this disaster.


On Thu, Jun 21, 2012 at 6:27 PM, Swinney, Austin <Austin at vimeo.com> wrote:

>  Hey Nick,
>
>  Not solving your problem, but I known the
> excited-why-wont-this-work-right-now sentiment.  I had a riak cluster up
> and running in very little time using Centos 5.6 and the rpm's from basho
> (riak-1.1.1-1.el5.x86_64.rpm). No errors, and as I recall, no requirements.
>   Adding addition nodes is no time at all.  But then, my stuff is on ec2
> using:
>
>   RightImage_CentOS_5.6_x64_v5.6.35 (ami-991adcf0)
>
>  Best of luck,
>
>  Austin
>
>  On Jun 21, 2012, at 12:55 PM, Nick Tune wrote:
>
> Now I've got an ubuntu VM and I'm getting this error:
>
>  Command 'generate' not understood or not applicable
>
>
> On Thu, Jun 21, 2012 at 5:48 PM, Nick Tune <nick.tune at 7digital.com> wrote:
>
>>
>>
>> ---------- Forwarded message ----------
>> From: Nick Tune <nick.tune at 7digital.com>
>> Date: Thu, Jun 21, 2012 at 5:25 PM
>> Subject: Re: Cannot Install Riak
>> To: Bogunov <bogunov at gmail.com>
>>
>>
>> Hello,
>>
>>  Thanks for the help. I made some progress and I got it working using
>> the 1.1.2 build.
>>
>>  But I wanted to try multiple nodes on local machine which requires a
>> build from source. Now I'm getting more issues.
>>
>>  Please see here:
>> http://stackoverflow.com/questions/11139149/escript-riak-1-1-2-rel-riak-erts-5-8-5-bin-nodetool
>>
>>  Thanks for your time. Sorry if I sound moody. This just annoyed me
>> because I was so excited to play with riak and erlang. ah well - such is
>> life.
>>
>>
>> On Thu, Jun 21, 2012 at 5:23 PM, Bogunov <bogunov at gmail.com> wrote:
>>
>>> Its possible what you don`t have one of required libraries, it seems
>>> you  are missing something from protobuf requirements, try building from
>>> scratch manually.
>>> just cd to protobuff dir and ./configure and make.
>>> 21.06.2012 19:30 пользователь "Nick Tune" <nick.tune at 7digital.com>
>>> написал:
>>>
>>> >
>>> > After pulling down riak from get, I get the following error when
>>> running make rel:
>>> >
>>> > ./rebar compile generate
>>> > ==> cluster_info (compile)
>>> > ==> lager (compile)
>>> > ==> poolboy (compile)
>>> > ==> protobuffs (compile)
>>> > make: *** [rel] Error 1
>>> >
>>> >
>>> > I've had an awful experience getting riak setup. I've wasted two hours
>>> messing around and it still doesn't work. Please improve the experience for
>>> other users.
>>> >
>>>  > _______________________________________________
>>> > riak-users mailing list
>>> > riak-users at lists.basho.com
>>> > http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>>> >
>>>
>>>
>>
>>
>  _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20120621/4d48b237/attachment.html>


More information about the riak-users mailing list