Riak basho bench error when running http_raw driver

Andrew Whang andrewgwhang at yahoo.com
Tue Mar 6 20:32:14 EST 2012


Thanks Dave. Robert Lowe also informed me of this: 

https://github.com/basho/basho_bench/pull/25

The combination of the two suggestions worked. Thanks!

Andrew 


On Tuesday, March 6, 2012 at 8:06 AM, David Smith wrote:

> You need to wrap the key generator with int_to_str, I believe.
> 
> {key_generator, {int_to_str, {uniform_int, 10000}}}.
> 
> D.
> 
> On Mon, Mar 5, 2012 at 3:04 PM, Andrew Whang <andrewgwhang at yahoo.com (mailto:andrewgwhang at yahoo.com)> wrote:
> > Hi,
> > 
> > I'm trying to run the basho bench tool against my Riak cluster using the
> > http_raw driver, and am coming across the following error:
> > 
> > =ERROR REPORT==== 5-Mar-2012::13:58:09 ===
> > ** Generic server <0.430.0> terminating
> > ** Last message in was {send_req,
> >                            {{url,undefined,"127.0.0.1",8098,undefined,
> >                                 undefined,"/riak/test/5526",undefined},
> >                             [],get,[],
> >                             [{response_format,binary}],
> >                             5000}}
> > ** When Server state == {state,"127.0.0.1",8098,undefined,#Ref<0.0.0.1604>,
> >                                false,undefined,[],false,undefined,false,[],
> >                                {[],[]},
> > 
> >  undefined,idle,undefined,<<>>,0,0,[],undefined,
> > 
> >  undefined,undefined,undefined,false,undefined,
> >                                undefined,<<>>,undefined,false,undefined,0,
> >                                undefined}
> > ** Reason for termination ==
> > ** {function_clause,
> >        [{ibrowse_http_client,send_req_1,
> >             [{<0.65.0>,#Ref<0.0.0.1605>},
> >              {url,undefined,"127.0.0.1",8098,undefined,undefined,
> >                  "/riak/test/5526",undefined},
> >              [],get,[],
> >              [{response_format,binary}],
> >              5000,
> >              {state,"127.0.0.1",8098,undefined,#Ref<0.0.0.1604>,false,
> >                  undefined,[],false,undefined,false,[],
> >                  {[],[]},
> >                  undefined,idle,undefined,<<>>,0,0,[],undefined,undefined,
> > 
> >  undefined,undefined,false,undefined,undefined,<<>>,undefined,
> >                  false,undefined,0,undefined}],
> >             [{file,"src/ibrowse_http_client.erl"},{line,619}]},
> >         {gen_server,handle_msg,5,[{file,"gen_server.erl"},{line,578}]},
> >         {proc_lib,init_p_do_apply,3,[{file,"proc_lib.erl"},{line,227}]}]}
> > 
> > My config:
> > 
> > {mode, max}.
> > {duration, 1}.
> > {concurrent, 3}.
> > {driver, basho_bench_driver_http_raw}.
> > {key_generator, {uniform_int, 10000}}.
> > {value_generator, {fixed_bin, 10000}}.
> > {http_raw_path, "/riak/test"}.
> > {operations, [{get, 1}, {update, 1}]}.
> > 
> > Any help debugging this error would be great.
> > 
> > Thanks,
> > Andrew
> > 
> > _______________________________________________
> > riak-users mailing list
> > riak-users at lists.basho.com (mailto:riak-users at lists.basho.com)
> > http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
> > 
> 
> 
> 
> 
> -- 
> Dave Smith
> VP, Engineering
> Basho Technologies, Inc.
> dizzyd at basho.com (mailto:dizzyd at basho.com)
> 
> 


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20120306/c15de5cf/attachment.html>


More information about the riak-users mailing list