Client wire compatibility between versions

Brian Roach roach at basho.com
Wed Mar 7 11:27:32 EST 2012


Jacques - 

Older client -> newer Riak shouldn't pose any issues. 

Newer client -> older Riak should also be fine with the caveat that any attempts to use features that are not present in the older version of Riak will of course fail. 

Thanks,
Brian Roach


On Mar 1, 2012, at 10:17 AM, Jacques wrote:

> What is the client compatibility between the various versions of servers?
> 
> For example, will the latest riak-java-client work against .14, 1.0 and 1.1?
> Will a PB client used during the .14 era work against the 1.0 and 1.1 servers?
> 
> Thanks,
> Jacques
> 
> 
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com





More information about the riak-users mailing list