Solving "bad_utf8_character_code" error returned by Riak MR

Matthew Tovbin matthew at tovbin.com
Fri Mar 9 15:32:15 EST 2012


Thanks, Sean!

What are the suggestions for solving this issue, except of cleaning data
before putting it to Riak?


-Matthew



On Fri, Mar 9, 2012 at 10:38, Sean Cribbs <sean at basho.com> wrote:

> Matthew,
>
> Even if your map function doesn't use the object, the Erlang side doesn't
> know that (Javascript funargs are exceptionally lazy anyway). It will still
> try to serialize the object into JSON to send marshal it into the VM.
> That's where the error is generated.
>
> On Fri, Mar 9, 2012 at 12:20 PM, Matthew Tovbin <matthew at tovbin.com>wrote:
>
>>  Good day!
>>
>>   As previously discussed here (
>> https://github.com/basho/riak_kv/pull/252#issuecomment-4415767) I am
>> unable to perform MR on my cluster due to wrong encoding in some of my
>> values.
>>
>> What are the suggestions for solving this issue, except of cleaning data
>> before putting it to Riak?
>>
>> Why does even this map function fail "function map () { return [1]; }" ? It's
>> not supposed to parse the value.
>>
>>
>> Thanks in advance for any tips.
>>
>> -Matthew
>>
>>
>> _______________________________________________
>> riak-users mailing list
>> riak-users at lists.basho.com
>> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>>
>>
>
>
> --
> Sean Cribbs <sean at basho.com>
> Software Engineer
> Basho Technologies, Inc.
> http://basho.com/
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20120309/eaf43d27/attachment.html>


More information about the riak-users mailing list