Javascript VMs don't start

Steve Warren swarren at myvest.com
Sun May 20 09:33:22 EDT 2012


Thanks Sam, I've been through the threads and while there was a suggested
fix for 1.1.1 it does not apply to 1.1.2.

Regards
Steve

On Sun, May 20, 2012 at 3:35 AM, Samuel Elliott <sam at lenary.co.uk> wrote:

> There have been quite a few emails about this problem on this mailing
> list - It's to do with the javascript VM (used for js MR steps)
> erroring. I'm not sure if there's a fix, but other threads will help
> you. Mailing list archives are here:
> http://erlang.org/pipermail/erlang-questions/
>
> Sam
>
> On Sun, May 20, 2012 at 5:39 AM, Steve Warren <swarren at myvest.com> wrote:
> > I'm running a newly installed 1.1.2 release of riak (evaluating it for
> use)
> > and I'm getting the prelist_exhausted error on my first map reduce
> attempt.
> > Searching the list gave me some clues so I found the "VMs are all busy"
> > error in the console log and I see the following when I execute this rpc
> > call on one of the nodes:
> >
> > rpc:multicall(riak_kv_js_manager,pool_size,[riak_kv_js_map]).
> > {"\b\b\b\b\b",[]}
> >
> > I don't see any other log or error messages so I don't determine why the
> JS
> > VMs are not starting properly. Has anyone seen and/or resolved this on
> > 1.1.2?
> >
> > Regards
> >
> > _______________________________________________
> > riak-users mailing list
> > riak-users at lists.basho.com
> > http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
> >
>
>
>
> --
> Samuel Elliott
> sam at lenary.co.uk
> http://lenary.co.uk/
> +44 (0)7891 993 664
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20120520/b51d62e0/attachment.html>


More information about the riak-users mailing list