Riak Search turns out results that's deleted?

Shuhao Wu admin at thekks.net
Wed May 30 10:55:06 EDT 2012


I'm encountering a weird case where it only happens on this specific bucket.

>>> import riak
>>> c = riak.RiakClient()
>>> b = c.bucket("test_search")
>>> b.get_keys()
[]
>>> c.search("test_search", "intprop:2").run()
[<riak.mapreduce.RiakLink object at 0x2c2e450>, <riak.mapreduce.RiakLink
object at 0x2c2e490>, <riak.mapreduce.RiakLink object at 0x2c2e4d0>,
<riak.mapreduce.RiakLink object at 0x2c2e510>, <riak.mapreduce.RiakLink
object at 0x2c2e550>, <riak.mapreduce.RiakLink object at 0x2c2e590>,
<riak.mapreduce.RiakLink object at 0x2c2e5d0>, <riak.mapreduce.RiakLink
object at 0x2c2e610>, <riak.mapreduce.RiakLink object at 0x2c2e650>,
<riak.mapreduce.RiakLink object at 0x2c2e690>, <riak.mapreduce.RiakLink
object at 0x2c2e6d0>, <riak.mapreduce.RiakLink object at 0x2c2e710>,
<riak.mapreduce.RiakLink object at 0x2c2e750>, <riak.mapreduce.RiakLink
object at 0x2c2e790>, <riak.mapreduce.RiakLink object at 0x2c2e7d0>,
<riak.mapreduce.RiakLink object at 0x2c2e810>, <riak.mapreduce.RiakLink
object at 0x2c2e850>, <riak.mapreduce.RiakLink object at 0x2c2e890>,
<riak.mapreduce.RiakLink object at 0x2c2e8d0>, <riak.mapreduce.RiakLink
object at 0x2c2e910>, <riak.mapreduce.RiakLink object at 0x2c2e950>,
<riak.mapreduce.RiakLink object at 0x2c2e990>, <riak.mapreduce.RiakLink
object at 0x2c2e9d0>, <riak.mapreduce.RiakLink object at 0x2c2ea10>,
<riak.mapreduce.RiakLink object at 0x2c2ea50>, <riak.mapreduce.RiakLink
object at 0x2c2ea90>, <riak.mapreduce.RiakLink object at 0x2c2ead0>,
<riak.mapreduce.RiakLink object at 0x2c2eb10>, <riak.mapreduce.RiakLink
object at 0x2c2eb50>, <riak.mapreduce.RiakLink object at 0x2c2eb90>,
<riak.mapreduce.RiakLink object at 0x2c2ebd0>, <riak.mapreduce.RiakLink
object at 0x2c2ec10>, <riak.mapreduce.RiakLink object at 0x2c2ec50>]
>>> b.get(c.search("test_search", "intprop:2").run()[0].get_key()).exists()
False

Note: Previously I have an object with the json document of {"intprop" : 2}

Any ideas why this is happening?

Shuhao
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20120530/30528d1e/attachment.html>


More information about the riak-users mailing list