node failure

Venki Yedidha venkatesh.yedidha at gmail.com
Tue Oct 30 02:19:40 EDT 2012


Hi All,
    I have a five node riak cluster running from the past three
months.Daily we are dumping huge data into the cluster..Somehow, I came to
notice that one of the nodes went down..we thought of removing that node
from the cluster because it is of very low configuration when compared to
other servers in the cluster..but in order to remove that node using
'cluster leave', it is saying the node needs to be up to remove it from the
cluster..

     Coming to the node(under repair)...I got duplicate error name when
trying bin/riak console...I checked whether erlang node name is identical
with any other in the cluster or not...I found no similar node..

I also checked whether there is any other process running or not...no other
process is running..

I changed ip to 127.0.0.1 in app.config and vm.args file...It worked for me

Finally, I deleted the ring directory contents, renamed 127.0.0.1 to
***.***.***.***

Now, my node is running successfully...

Finally, I tried to remove it from the cluster going to one of the active
nodes...

I ended up with this:

FALSE Node 'riak@***.***.***.***' and 'riak at 10.***.***.***' list different
partition owners

I guess it is because of the ring directory I deleted in the node under
repair...

Please help me removing that node from the cluster..

Thanks,
Venkatesh
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20121030/1e329318/attachment.html>


More information about the riak-users mailing list