Riak 1.2: stalled handoff

Yuri Lukyanov snaky at aboutecho.com
Fri Apr 5 18:30:50 EDT 2013


Hi,

I was adding the 7-th node to one of our riak 1.2 clusters. Everything was
ok untill the process suddenly stopped with one handoff left:

# riak-admin transfers
Attempting to restart script through sudo -H -u riak
riak at nsto0r6 waiting to handoff 1 partitions

Active Transfers:


Note that no transfers are displayed. At first I thought that it is just a
temporary pause. But it's been already about 12 hours since then.

Here is what member-status shows:

# riak-admin member-status
Attempting to restart script through sudo -H -u riak
================================= Membership
==================================
Status     Ring    Pending    Node
-------------------------------------------------------------------------------
valid      14.1%     14.1%    riak at nsto0r0
valid      14.1%     14.1%    riak at nsto0r1
valid      14.1%     14.1%    riak at nsto0r2
valid      14.1%     14.1%    riak at nsto0r3
valid      15.6%     15.6%    riak at nsto0r4
valid      *15.6%     14.1%*    riak at nsto0r5
valid      *12.5%     14.1%*    riak at nsto0r6
-------------------------------------------------------------------------------
Valid:7 / Leaving:0 / Exiting:0 / Joining:0 / Down:0


What would be a reason for such behaviour and how can I investigate this
further?
How to force the handoff?

Thanks.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20130406/ebd81dd7/attachment.html>


More information about the riak-users mailing list