Riak 1.3.1 refusing to start up

Chris Read chris.read at gmail.com
Wed Apr 24 06:25:57 EDT 2013


Excellent, thanks! Bug in our chef template for vm.args messed up the the
name. All good now.


On Wed, Apr 24, 2013 at 10:51 AM, Eric Redmond <eredmond at basho.com> wrote:

> This commonly happens if a node name or IP has changed args.vm -name
> without notifying the ring. Either use the riak-admin cluster replaced
> command, or delete the ring directory and rejoin the cluster.
>
> Note this isn't the only reason for missing capabilities, but a very
> common one.
>
> Sent from my iPhone
>
> On Apr 24, 2013, at 11:11 AM, Chris Read <chris.read at gmail.com> wrote:
>
> > Greetings all...
> >
> > I've got a riak cluster that's now refusing to start. We're running
> version 1.3.1 on 3 nodes, all of them fail to start with the following
> error in console.log:
> >
> > 2013-04-24 04:05:15.518 [error] <0.152.0> gen_server
> riak_core_capability terminated with reason: no function clause matching
> orddict:fetch(riak at in, []) line 72
> > 2013-04-24 04:05:15.522 [error] <0.152.0> CRASH REPORT Process
> riak_core_capability with 0 neighbours exited with reason: no function
> clause matching orddict:fetch(riak at in, []) line 72 in
> gen_server:terminate/6 line 747
> > 2013-04-24 04:05:15.527 [error] <0.133.0> Supervisor riak_core_sup had
> child riak_core_capability started with riak_core_capability:start_link()
> at <0.152.0> exit with reason no function clause matching
> orddict:fetch(riak at in, []) line 72 in context child_terminated
> > 2013-04-24 04:05:15.529 [error] <0.131.0> CRASH REPORT Process <0.131.0>
> with 0 neighbours exited with reason:
> {{function_clause,[{orddict,fetch,[riak at in,[]],[{file,"orddict.erl"},{line,72}]},{riak_core_capability,renegotiate_capabilities,1,[{file,"src/riak_core_capability.erl"},{line,415}]},{riak_core_capability,handle_call,3,[{file,"src/riak_core_capability.erl"},{line,208}]},{gen_server,handle_msg,5,[{file,"gen_server.erl"},{line,588}]},{proc_lib,init_p_do_apply,3,[{file,"proc_lib.erl"},{line,227}]}]},{gen_server,call,[riak_core_capability,{register,{riak_core,vnode_routing},{capability,[proxy,legacy],...}},...]}}
> in application_master:init/4 line 138
> > 2013-04-24 04:05:15.531 [info] <0.7.0> Application riak_core exited with
> reason: {{function_clause,[{orddict,fetch,[riak at in
> ,[]],[{file,"orddict.erl"},{line,72}]},{riak_core_capability,renegotiate_capabilities,1,[{file,"src/riak_core_capability.erl"},{line,415}]},{riak_core_capability,handle_call,3,[{file,"src/riak_core_capability.erl"},{line,208}]},{gen_server,handle_msg,5,[{file,"gen_server.erl"},{line,588}]},{proc_lib,init_p_do_apply,3,[{file,"proc_lib.erl"},{line,227}]}]},{gen_server,call,[riak_core_capability,{register,{riak_core,vnode_routing},{capability,[proxy,legacy],...}},...]}}
> >
> > Any ideas?
> >
> > Chris
> > _______________________________________________
> > riak-users mailing list
> > riak-users at lists.basho.com
> > http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20130424/e87a55ed/attachment.html>


More information about the riak-users mailing list