cloned machines issues

Pieter Breed lists.basho.com at pb.co.za
Sat Apr 27 05:56:23 EDT 2013


Hi,

I'm trying to get two cloned machines to form a new cluster but I'm
struggling to get rid of the old cluster config.

10.10.12.47 and 10.10.12.48 were the two machines the clones were made from
10.10.12.75 and 10.10.12.95 are the new machines' ip

I updated the /var/lib/riak/.erlang.cookie file on both machines to
the same value
I changed the /etc/riak/* files to use the new ips
I ran the reip command, which on both machines succeeded

riak ping responds on both machines with pong

running riak-admin status on both machines shows this:

ring_members : ['riak at 10.10.12.47','riak at 10.10.12.48','riak at 10.10.12.75',
                'riak at 10.10.12.95']
ring_num_partitions : 64
ring_ownership : <<"[{'riak at 10.10.12.75',18},\n
{'riak at 10.10.12.95',18},\n {'riak at 10.10.12.47',14},\n
{'riak at 10.10.12.48',14}]">>

As you can see the old ip's are still considered part of the cluster,
but they should not be.

I tried this: riak-admin cluster force-remove riak at 10.10.12.47
Attempting to restart script through sudo -H -u riak
Remove failed, see log for details

/var/log/riak/console.log shows this in the last few lines:

2013-04-27 11:39:28.442 [info] <0.41.0> alarm_handler:
{set,{system_memory_high_watermark,[]}}
2013-04-27 11:39:50.528 [info]
<0.325.0>@riak_core:wait_for_service:445 Waiting for service riak_kv
to start (60 seconds)
2013-04-27 11:41:12.231 [info]
<0.325.0>@riak_core:wait_for_service:439 Wait complete for service
riak_kv (119 seconds)
2013-04-27 11:41:24.962 [error]
<0.1648.0>@riak_core_console:stage_remove:234 Remove failed
exit:{{nodedown,undefined},{gen_server,call,[{riak_core_claimant,undefined},{stage,'riak at 10.10.12.47',remove},infinity]}}

It kind of makes sense because those other ip's are not running at the moment.

Can anyone help me to get rid of those machines in the new cluster?

Regards,
Pieter
--
Give a man fire, he will be warm for a night ; set a man on fire and
he will be warm for the rest of his life.




More information about the riak-users mailing list