Building a Development Environment: Can't PUT image

Chas. Munat chas at munat.com
Wed Feb 27 14:57:07 EST 2013


I'm following the Building a Development Environment part of the 
tutorial. I have a four node cluster. By viewing the app.config files, 
I've determined that the individual nodes respond on ports 10018, 10028, 
10038, and 10048. But I can't see anywhere where the port used to 
address the cluster as a whole is provided.

I have tried putting an image using the provide CURL call:

curl -XPUT http://127.0.0.1:xxxx/riak/images/1.jpg \
   -H "Content-type: image/jpeg" \
   --data-binary yyyy.jpg

Substituting 10018 for xxxx, and the filename of my image for yyyy. I'm 
running this from the dev directory and the image is in the same 
directory. I've tried it with a ./ to be sure, and have even tried it 
with sudo thinking it might be permissions.

The call to CURL returns without comment. If I use a bad port, it 
returns an error. When I go to http://127.0.0.1:xxxx/riak/images/1.jpg 
substituting the same port for xxxx, I get a broken image link. So it's 
trying to put the image there, but the image isn't being copied.

What am I doing wrong? And how can I figure out which port to use?

TIA!

Chas. Munat
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20130227/b04946e4/attachment.html>


More information about the riak-users mailing list