Wiping data directory break vnodes with read_block_error

Jonas Lindmark jonas.lindmark at gmail.com
Thu Feb 28 03:47:12 EST 2013


I realize now that read_block_error, <<"0">> means that there was not an
error...

I still get problems when running my integration tests:
{insufficient_vnodes,0,need,2}
status code 0

Could it be a timing issue where I start my integration tests too early
after 'riak start'?


On 28 February 2013 08:55, Jonas Lindmark <jonas.lindmark at gmail.com> wrote:

> Hi,
>
> I'm looking for a way to manually wipe the data off of a single-node riak
> installation. I'm using riak (1.3.0 2013-02-19) Debian x86_64 with the
> riak_kv_eleveldb_backend.
>
> What I'm currently doing is:
>
>
>    - riak stop
>    - rm -rf /var/lib/riak
>    - mkdir riak
>    - chown riak:riak riak
>    - start riak
>
> Riak starts ok but a riak-admin vnode-status gives me:
>
> Backend: riak_kv_eleveldb_backend
> Status:
> [{stats,<<"                               Compactions\nLevel  Files
> Size(MB) Time(sec) Read(MB)
> Write(MB)\n--------------------------------------------------\n">>},
>  {read_block_error,<<"0">>}]
>
> For each vnode.
>
> It seems to me that there is something more I need to wipe for this to
> work but I can't find which files that would be.
>
> /Jonas
>



-- 
/Jonas
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20130228/9e58f9f7/attachment.html>


More information about the riak-users mailing list