riak-users Digest, Vol 40, Issue 3

Evan Vigil-McClanahan emcclanahan at basho.com
Thu Jan 17 00:48:58 EST 2013


Hi Sally.

That error can sometimes be misleading.  It's quite likely that
there's nothing wrong with your app.config, but there is something
wrong with nodetool.

What is the output when you run:
bash -x riak chkconfig
?


On Wed, Jan 16, 2013 at 9:25 PM, Sally Lehman <rothsa at gmail.com> wrote:
> Hi,
>
> I've spent many hours trying to figure out what's going on here with no
> resolution, any hint of where to look next would be greatly appreciated.
>
> While trying to get riak 1.2.1-x86_64 started on Mac OS X Lion 10.7.5 to
> test it out and experiment, I'm running into this error:
>
> $ riak start
> Error reading /usr/local/Cellar/riak/1.2.1-x86_64/libexec/etc/app.config
>
> Trying to use $escript app.config to debug this I get:
>
> $ escript app.config
> app.config:2: syntax error before: '['
> escript: There were compilation errors.
>
> I'm absolutely positive that this app.config is syntactically correct, as an
> exactly identical app.config works for people I know with a similar OS and
> configuration.
>
> Here's the first five lines of code for the app.config:
>
> %% -*- mode: erlang;erlang-indent-level: 4;indent-tabs-mode: nil -*-
> %% ex: ft=erlang ts=4 sw=4 et
> [
>  %% Riak Client APIs config
>  {riak_api, [
>
> Thanks,
>
> Sally L
>
>
>
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>




More information about the riak-users mailing list