Riak fails to start

Daniel Iwan iwan.daniel at gmail.com
Mon Jan 21 11:08:18 EST 2013


Thanks Jon

Is there any timeframe for 1.3 release with maybe a glimpse of what
features we may expect?

Regards
Daniel


On 21 January 2013 14:42, Jon Meredith <jmeredith at basho.com> wrote:

> Thanks for reporting the issue and sorry you got bitten by it.  We have
> committed a fix to master a couple of months ago and it will appear in the
> 1.3 release.
>
> Jon
>
> On Jan 21, 2013, at 3:58 AM, Daniel Iwan <iwan.daniel at gmail.com> wrote:
>
> THe issue was that one of the ring snapshot files had size 0
>
> user at node1:~$ ls -la /var/lib/riak/ring/
> total 32
> drwxr-xr-x 2 riak riak   138 Jan 17 10:27 .
> drwxr-xr-x 7 riak riak   129 Jan 17 13:22 ..
> -rw-rw-r-- 1 riak riak 12584 Jan 15 17:19
> riak_core_ring.default.20130115171955
> -rw-rw-r-- 1 riak riak 12584 Jan 17 10:27
> riak_core_ring.default.20130117102756
> -rw-rw-r-- 1 riak riak     0 Jan 17 10:27
> riak_core_ring.default.20130117102757
>
> After deleting it riak process started correctly.
> I guess riak process should check if ring file is corrupted or 0 bytes
> long, delete/rename it automatically
> and use previous version?
>
> Regards
> Daniel
>
>
>
> On 17 January 2013 14:00, Daniel Iwan <iwan.daniel at gmail.com> wrote:
>
>> One of our nodes fails to start
>>
>> $ sudo riak console
>> Attempting to restart script through sudo -H -u riak
>> Exec: /usr/lib/riak/erts-5.9.1/bin/erlexec -boot
>> /usr/lib/riak/releases/1.2.1/riak             -embedded -config
>> /etc/riak/app.config             -pa /usr/lib/riak/lib/basho-patches
>>         -args_file /etc/riak/vm.args -- console
>> Root: /usr/lib/riak
>> Erlang R15B01 (erts-5.9.1) [source] [64-bit] [smp:4:4] [async-threads:64]
>> [kernel-poll:true]
>>
>> ** /usr/lib/riak/lib/basho-patches/etop_txt.beam hides
>> /usr/lib/riak/lib/observer-1.1/ebin/etop_txt.beam
>> ** Found 1 name clashes in code paths
>> 13:22:47.424 [info] Application lager started on node 'riak at 10.173.240.1'
>> 13:22:47.466 [error] CRASH REPORT Process <0.149.0> with 0 neighbours
>> exited with reason: bad argument in call to erlang:binary_to_term(<<>>) in
>> riak_core_ring_manager:read_ringfile/1 line 154 in gen_server2:init_it/6
>> line 384
>> /usr/lib/riak/lib/os_mon-2.2.9/priv/bin/memsup: Erlang has closed.
>>                                                                    Erlang
>> has closed
>>
>>           {"Kernel pid terminated",application_controller,"{application_
>> start_failure,riak_core,{shutdown,{riak_core_app,start,[normal,[]]}}}"}
>>
>> Crash dump was written to: /var/log/riak/erl_crash.dump
>> Kernel pid terminated (application_controller)
>> ({application_start_failure,riak_core,{shutdown,{riak_
>> core_app,start,[normal,[]]}}})
>>
>>
>> Which suggest that something happened to ring files?
>>
>> Any idea what and why it happened?
>>
>> Dump file available at:
>> http://www.filedropper.com/erlcrash
>>
>> Regards
>> Daniel
>>
>>
>>
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20130121/839049f6/attachment.html>


More information about the riak-users mailing list