testing Riak (incomplete doc)

Andrey Somov public.somov at gmail.com
Mon Jan 28 14:25:08 EST 2013


Thank you. It works after this:

./kerl install r15b01 ~/erlang/r15b01
. ~/erlang/r15b01/activate


When I run the tests in the master branch, I got:

 Failed: 24.  Skipped: 0.  Passed: 221.

I wanted to contribute, but how do I know that I have not broken something
if the tests normally fail ?

Cheers,
Andrey


On Sun, Jan 27, 2013 at 10:14 PM, Jared Morrow <jared at basho.com> wrote:

> You don't appear to have erlang in your path that's why the escript is
> failing.
>
> -Jared
>
>
> On Jan 27, 2013, at 1:16 PM, Andrey Somov <public.somov at gmail.com> wrote:
>
> Hi all,
> I have just tried to run the tests for riak_kv as described here:
> https://github.com/basho/riak
>
> Both 'make eunit' and 'rebar' fail:
>
> ~/projects/riak_kv$ make eunit
> make: *** No rule to make target `eunit'.  Stop.
> ~/projects/riak_kv$ ./rebar skip_deps=true eunit
> /usr/bin/env: escript: No such file or directory
>
> What should I do to run the tests ? Should the documentation be updated to
> add the dependencies?
>
> Cheers,
> Andrey
>
>
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20130128/f9dd3d60/attachment.html>


More information about the riak-users mailing list