Riak startup failing.

Charlie Voiselle cvoiselle at basho.com
Mon Jan 28 15:06:10 EST 2013


Kevin:

First things first. What version of Riak are you running? The `riak-admin cluster` commands are available as of Riak 1.2.0. Next, if you have already renamed all of the nodes, you will need to use the `reip` method to modify all of the ring files on each of the nodes.  If you are able, it's easier to roll back the changes to the configuration and get the nodes starting again.  

Once they are started and running, here's a writeup of the scheme you would use to do the rolling configuration changes: https://gist.github.com/4566736

Thanks,
Charlie Voiselle

On Dec 29, 2012, at 1:02 PM, Kevin Burton <rkevinburton at charter.net> wrote:

> Here is what I found out (I am still stuck)  https://github.com/basho/basho_docs/issues/28
>  
>  
> The step says to rename or remove the data/ring directory. My data directory is /var/lib/riak. If I rename or remove that directory then no commands work. I have assumed it meant to rename or remove just the ring directory which is for me /var/lib/riak/ring. When the node is restarted the ring directory is recreated.
> When I issue riak-admin down (I have to specify the node name since it is required) I get errors/warnings:
>  
> ~$ sudo riak-admin down riak at xxx.xxx.xxx.xxx
> Attempting to restart script through sudo -H -u riak
> Node is not running!
>  
> I am not sure what it means to join the existing cluster on the first node.  Is this riak-admin cluster join? For the first node I get an error
>  
> ~$ sudo riak-admin cluster join riak at xxx.xxx.xxx.xxx
> Attempting to restart script through sudo -H -u riak
> Join failed. Try again in a few moments.
>  
> There is no ‘force-replace’ argument to riak-admin and that command seems to be deprecated. There is a force-replace for riak-admin cluster but it takes two nodes as arguments which I am not sure what to put there. What should I use?
>  
> These steps seem to get me further but still there are gaps (at least for me).
>  
>  
>  
>  
>  
>  
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20130128/ede8a428/attachment.html>


More information about the riak-users mailing list