Can't start Riak. Erlang crashes immediately. Memory problem?

prog112 prog112 at gmail.com
Thu Jul 11 03:33:09 EDT 2013


So I'm running Riak on my VPS Linux machine. I've got 2GB of RAM available so
I decided to go with eleveldb backend and I tuned the parameters a bit.
However, I can't start my node at all. There are no errors during the riak
start command but inspecting the logs show up different messages:


2013-07-11 09:21:20 =CRASH REPORT====
  crasher:
    initial call: riak_kv_index_hashtree:init/1
    pid: <0.755.0>
    registered_name: []
    exception exit:
{{undef,[{eleveldb,open,["/var/lib/riak/anti_entropy/0",[{create_if_missing,true},{max_open_files,20},{write_buffer_size,10671541}]],[]},{hashtree,new_segment_store,2,[{file,"src/hashtree.erl"},{line,499}]},{hashtree,new,2,[{file,"src/hashtree.erl"},{line,215}]},{riak_kv_index_hashtree,do_new_tree,2,[{file,"src/riak_kv_index_hashtree.erl"},{line,426}]},{lists,foldl,3,[{file,"lists.erl"},{line,1197}]},{riak_kv_index_hashtree,init_trees,2,[{file,"src/riak_kv_index_hashtree.erl"},{line,368}]},{riak_kv_index_hashtree,init,1,[{file,"src/riak_kv_index_hashtree.erl"},{line,225}]},{gen_server,init_it,6,[{file,"gen_server.erl"},{line,304}]}]},[{gen_server,init_it,6,[{file,"gen_server.erl"},{line,328}]},{proc_lib,init_p_do_apply,3,[{file,"proc_lib.erl"},{line,227}]}]}
    ancestors: [<0.707.0>,riak_core_vnode_sup,riak_core_sup,<0.130.0>]
    messages: []
    links: []
    dictionary: []
    trap_exit: false
    status: running
    heap_size: 1597
    stack_size: 24
    reductions: 431
  neighbours:

Also:

=====
===== LOGGING STARTED Thu Jul 11 09:24:35 CEST 2013
=====
Exec: /usr/lib/riak/erts-5.9.1/bin/erlexec -boot
/usr/lib/riak/releases/1.3.2/riak             -embedded -config
/etc/riak/app.config             -pa /usr/lib/riak/lib/basho-patches            
-args_file /etc/riak/vm.args -- console
Root: /usr/lib/riak
Erlang R15B01 (erts-5.9.1) [source] [64-bit] [smp:8:1] [async-threads:16]
[kernel-poll:true]

Eshell V5.9.1  (abort with ^G)
(riak at xxx)1> /usr/lib/riak/lib/os_mon-2.2.9/priv/bin/memsup: Erlang has
closed.
Erlang has closed

Anyone got any ideas for me?




--
View this message in context: http://riak-users.197444.n3.nabble.com/Can-t-start-Riak-Erlang-crashes-immediately-Memory-problem-tp4028271.html
Sent from the Riak Users mailing list archive at Nabble.com.




More information about the riak-users mailing list