Expire feature doesn't seem to work in Riak 1.4.0

Shrikar archak shrikar84 at gmail.com
Tue Jul 16 18:52:54 EDT 2013


Hi All,


I am looking at the auto expire feature in Riak and it seems that it
doesn't work.
Am I missing something here??

Here is the app config for the bitcask section

 {bitcask, [
             %% Configure how Bitcask writes data to disk.
             %%   erlang: Erlang's built-in file API
             %%      nif: Direct calls to the POSIX C API
             %%
             %% The NIF mode provides higher throughput for certain
             %% workloads, but has the potential to negatively impact
             %% the Erlang VM, leading to higher worst-case latencies
             %% and possible throughput collapse.
             {io_mode, erlang},

             {data_root, "/var/lib/riak/bitcask"},
*             {expire_secs, 30},*
*             {expire_grace_time, 3600},*
*             {merge_window, {0, 6}}*
           ]},

Also my backend is bitcask.


Test :

curl -XPOST http://192.168.8.61:8098/riak/test/hello -d '{"shrikar":"test"}'

wait for more than 30 seconds in my case I waited for upto a minute.

Shrikars-MacBook-Pro:~ shrikar$ curl -v
http://192.168.8.61:8098/riak/test/hello
* About to connect() to 192.168.8.61 port 8098 (#0)
*   Trying 192.168.8.61...
* connected
* Connected to 192.168.8.61 (192.168.8.61) port 8098 (#0)
> GET /riak/test/hello HTTP/1.1
> User-Agent: curl/7.24.0 (x86_64-apple-darwin12.0) libcurl/7.24.0
OpenSSL/0.9.8x zlib/1.2.5
> Host: 192.168.8.61:8098
> Accept: */*
>
< HTTP/1.1 200 OK
< X-Riak-Vclock: a85hYGBgzGDKBVIcHpu2/Al8euxyBlMiax4rQ7Jn1Gm+LAA=
< Vary: Accept-Encoding
< Server: MochiWeb/1.1 WebMachine/1.10.0 (never breaks eye contact)
< Link: </riak/test>; rel="up"
< Last-Modified: Tue, 16 Jul 2013 22:46:59 GMT
< ETag: "7ZFMTDwc4re4Z7v3RIaDFE"
< Date: Tue, 16 Jul 2013 22:52:13 GMT
< Content-Type: application/x-www-form-urlencoded
< Content-Length: 18
<
* Connection #0 to host 192.168.8.61 left intact
*{"shrikar":"test"}** Closing connection #0

Am I missing something here??


Thanks,
Shrikar
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20130716/189a8398/attachment.html>


More information about the riak-users mailing list