Help... Something is wrong with my restore

John Daily jdaily at basho.com
Thu Jul 18 15:00:37 EDT 2013


Per http://docs.basho.com/riak/latest/cookbooks/Backups/, you need not only Bitcask data but also ring data and configuration.

-John

On Jul 18, 2013, at 1:40 PM, Mark Wagner <mwagner72 at gmail.com> wrote:

> Here is what I am doing:   on OSX
> 
> # Install riak on my local OSX development box 
> brew install riak
> 
> riak start
> riak-admin test
> Successfully completed 1 read/write cycle to 'riak at 127.0.0.1'
> riak stop
> 
> #goto the default data directory setup by brew
> cd ~/Developer/Cellar/riak/1.3.1-x86_64/libexec/data/bitcask/
> 
> # create a bitcask directory and copy the bitcask data into it
> cp -r ~/Downloads/riak/var/lib/riak/bitcask/* ./
> 
> 
> riak start
> riak-admin test
> Failed to read test value: {error,{insufficient_vnodes,0,need,1}}
> 
> 
> I thought bitcask data just need to be copied in... and it would work??
> 
> 
> 
> -- 
> Mark Wagner, Web & Mobile Developer
> :coderow
> Web & mobile application development for business
> m: 480.580.1261 | o: 612.293.9090
> www.coderow.com | mark at coderow.com | @thesociableme
> 
> 
> 
> 
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20130718/3693e27f/attachment.html>


More information about the riak-users mailing list