Yokozuna kv write timeouts on 1.4 (yz-merge-1.4.0)

Ryan Zezeski rzezeski at basho.com
Thu Jul 18 17:06:10 EDT 2013


Okay.  Yokozuna has been targeted to Riak 1.4.0.  Please notice the
integration branch names changed to rz-yz-merge-1.4.0 (notice the addition
of rz- prefix and different version).

https://github.com/basho/yokozuna/blob/master/docs/INSTALL.md#install-from-github

Make sure to do a fresh checkout to avoid any lingering old dependencies.
 Let me know if you run into more issues.

-Z


On Thu, Jul 18, 2013 at 9:33 AM, Ryan Zezeski <rzezeski at basho.com> wrote:

> Dave,
>
> I'm currently in the process re-targeting Yokozuna to 1.4.0 for the 0.8.0
> release.  I'll ping this thread when the transition is complete.
>
> -Z
>
>
> On Wed, Jul 17, 2013 at 8:53 PM, Eric Redmond <eredmond at basho.com> wrote:
>
>> Dave,
>>
>> Your initial line was correct. Yokozuna is not yet compatible with 1.4.
>>
>> Eric
>>
>> On Jul 15, 2013, at 1:00 PM, Dave Martorana <dave at flyclops.com> wrote:
>>
>> Hi everyone. First post, if I leave anything out just let me know.
>>
>> I have been using vagrant in testing Yokozuna with 1.3.0 (the official
>> 0.7.0 “release") and it runs swimmingly. When 1.4 was released and someone
>> pointed me to the YZ integration branch, I decided to give it a go.
>>
>> I realize that YZ probably doesn’t support 1.4 yet, but here are my
>> experiences.
>>
>> - Installs fine
>> - Using default stagedevrel with 5 node setup
>> - Without yz enabled in app.config, kv accepts writes and reads
>> - With yz enabled on dev1 and nowhere else, kv accepts writes and reads,
>> creates yz index, associates index with bucket, does not index content
>> - With yz enabled on 4/5 nodes, kv stops accepting writes (timeout)
>>
>> Ex:
>>
>> (env)➜  curl -v -H 'content-type: text/plain' -XPUT '
>> http://localhost:10018/buckets/players/keys/name' -d "Ryan Zezeski"
>> * Adding handle: conn: 0x7f995a804000
>> * Adding handle: send: 0
>> * Adding handle: recv: 0
>> * Curl_addHandleToPipeline: length: 1
>> * - Conn 0 (0x7f995a804000) send_pipe: 1, recv_pipe: 0
>> * About to connect() to localhost port 10018 (#0)
>> *   Trying 127.0.0.1...
>> * Connected to localhost (127.0.0.1) port 10018 (#0)
>> > PUT /buckets/players/keys/name HTTP/1.1
>> > User-Agent: curl/7.30.0
>> > Host: localhost:10018
>> > Accept: */*
>> > content-type: text/plain
>> > Content-Length: 12
>> >
>> * upload completely sent off: 12 out of 12 bytes
>> < HTTP/1.1 503 Service Unavailable
>> < Vary: Accept-Encoding
>> * Server MochiWeb/1.1 WebMachine/1.9.2 (someone had painted it blue) is
>> not blacklisted
>> < Server: MochiWeb/1.1 WebMachine/1.9.2 (someone had painted it blue)
>> < Date: Mon, 15 Jul 2013 19:54:50 GMT
>> < Content-Type: text/plain
>> < Content-Length: 18
>> <
>> request timed out
>> * Connection #0 to host localhost left intact
>>
>> Here are my Vagrant file:
>>
>> https://gist.github.com/themartorana/460a52bb3f840010ecde
>>
>> and build script for the server:
>>
>> https://gist.github.com/themartorana/e2e0126c01b8ef01cc53
>>
>> Hope this helps.
>>
>> Dave
>>
>> _______________________________________________
>> riak-users mailing list
>> riak-users at lists.basho.com
>> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>>
>>
>>
>> _______________________________________________
>> riak-users mailing list
>> riak-users at lists.basho.com
>> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>>
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20130718/a0281f3a/attachment.html>


More information about the riak-users mailing list