Riak-CS Question

Vahric Muhtaryan vahric at gmail.com
Fri Jul 19 12:20:59 EDT 2013


Okay i will configure it and check it. Because of i am sending request to
only 245 i assume that no need to config. Why others are in action . Im
sending request to 245 ?
19 Tem 2013 19:07 tarihinde "Christian Dahlqvist" <christian at basho.com>
yazdı:

> Hi Vahric,
>
> The reason you are getting errors related to bit cask and indexing is that
> you only have configured the required multi backend on one of the Riak
> nodes. All the Riak nodes need to have the same backend configuration, as
> data will be replicated across the cluster.
>
> Best regards,
>
> Christian
>
>
>
> On 19 Jul 2013, at 15:32, Vahric Muhtaryan <vahric at gmail.com> wrote:
>
> attached, thanks
> VM
>
>
> On Fri, Jul 19, 2013 at 4:00 PM, Christian Dahlqvist <christian at basho.com>wrote:
>
>> Hi Vahric,
>>
>> Please can you send me the logs and configuration files from Riak,
>> Riak-CS and Stanchion from all nodes in the cluster?
>>
>> Best regards,
>>
>> Christian
>>
>>
>>
>>
>> On 18 Jul 2013, at 21:45, Vahric Muhtaryan <vahric at gmail.com> wrote:
>>
>> Hello All,
>>
>> i got such error
>>
>> [7/18/13 8:22:24 PM] Vahric MUHTARYAN: 2013-07-18 20:17:37.442 [warning]
>> <0.121.0>@stanchion_utils:email_available:591 Error occurred trying to
>> check if the address <<"vahric at doruk.net.tr">> has been registered.
>> Reason: <<"{error,{indexes_not_supported,riak_kv_bitcask_backend}}">>
>>
>> but my config should be okay
>>
>> {add_paths, ["/usr/lib64/riak-cs/lib/riak_cs-1.3.1/ebin"]},
>> {storage_backend, riak_cs_kv_multi_backend},
>> {multi_backend_prefix_list, [{<<"0b:">>, be_blocks}]},
>> {multi_backend_default, be_default},
>> {multi_backend, [
>>  {be_default, riak_kv_eleveldb_backend, [
>>    {max_open_files, 50},
>>      {data_root, "/var/lib/riak/leveldb"}
>>  ]},
>>    {be_blocks, riak_kv_bitcask_backend, [
>>      {data_root, "/var/lib/riak/bitcask"}
>>  ]}
>> ]},
>>
>> (riak at xxx.xxx.xxx.xxx)3> code:which(riak_cs_kv_multi_backend).
>>
>> "/usr/lib64/riak-cs/lib/riak_cs-1.3.1/ebin/riak_cs_kv_multi_backend.beam"
>>
>> Any idea why i can not create admin user when i try to create ? My config
>> said default db backend is level not bits cask, could be a bug ? Any body
>> know ?
>>
>> Regards
>> VM _______________________________________________
>> riak-users mailing list
>> riak-users at lists.basho.com
>> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>>
>>
>>
> <riak.zip>
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20130719/42e54b47/attachment.html>


More information about the riak-users mailing list