Performance problem: put operation takes seconds

Christian Dahlqvist christian at basho.com
Mon Jul 22 08:55:25 EDT 2013


Hello,

Please can you attach your app.config and vm.args files as well as a zipped up log directory from one of the nodes?

Best regards,

Christian


On 22 Jul 2013, at 12:40, ks <ksafonov at rutarget.ru> wrote:

> Hi there,
> 
> We're using Riak 1.3.1 cluster with 3 nodes (CentOS 64-bit, Intel® Xeon®
> E3-1245 Quadcore, 16 GB DDR3 RAM ECC, 2 x 3 TB SATA 6 Gb/s HDD 7200 rpm
> (Software-RAID 1)) connected to the same 10 Gb router.
> 
> We hold lot of small key-value pairs in the database and do about 500 get
> operations and about 500 put requests per second via Java client library
> from different client machines.
> 
> The problem is that 95% percentile (according to Riak statistics) often
> jumps up to 50000 ms for a couple of minutes. This is something quite far
> from we expected in terms of performance.
> 
> We've tried setting the options in
> http://docs.basho.com/riak/latest/cookbooks/Linux-Performance-Tuning/
> (except for noatime flag). But anyway, 50 seconds put timeout is something
> outstanding and I hardly believe noatime is a remedy.
> 
> Log files appeared to be somewhat unclear to track down the problem. 
> 
> Is there anything else we can try?
> 
> Thanks a lot!
> 
> 
> 
> --
> View this message in context: http://riak-users.197444.n3.nabble.com/Performance-problem-put-operation-takes-seconds-tp4028478.html
> Sent from the Riak Users mailing list archive at Nabble.com.
> 
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com





More information about the riak-users mailing list