Riak Java Client v1.4.1

Brian Roach roach at basho.com
Fri Jul 26 16:34:05 EDT 2013


Hot on the heels of 1.4.0 ...

After releasing 1.4.0 it was reported to us that if you tried to
switch to using protocol buffers in existing code and you were already
using protocol buffers 2.5.0 ... the client would crash.

Apparently Google has introduced breaking changes in Protocol Buffers
2.5.0 that make code generated with 2.4.1 incompatible.

To solve this problem we've decided to use the maven `shade` plugin to
repackage 2.4.1 and include it in the Riak Java Client jar. This is
the only difference between 1.4.0 and 1.4.1.

With the release of v2.0 we will be moving to Protocol Buffers 2.5.0

Thanks,
Brian Roach




More information about the riak-users mailing list