Unable to configure Riak-CS-Control to manage users

Dmitri Zagidulin dzagidulin at basho.com
Wed Oct 9 10:36:10 EDT 2013


Hi Siddhu,

Can you try changing 'cs_proxy_host' to localhost? So:

 {cs_proxy_host, "127.0.0.1" }.

and retry.




On Wed, Oct 9, 2013 at 9:55 AM, Siddhu Warrier (siwarrie) <
siwarrie at cisco.com> wrote:

>  Hi,
>
>  I have a two node Riak CS (1.4) cluster set up on two nodes (node-1 and
> node-2 henceforth). Node-1 is the headnode. Both node-1 and node-2 are
> running CentOS-6.4.
>
>  *N**ode-1*
>
>    - Riak 1.4.2
>    - Stanchion 1.4.1
>    - Riak-CS 1.4.1
>    - Riak-CS-Control 1.0.2
>
>  *N**ode-2*
>
>    - Riak 1.4.2
>    - Riak-CS 1.4.1
>
> I have got Riak CS working, and have created admin credentials that I've
> set correctly on stanchion, riak-cs, and riak-cs-control on node 1, and on
> riak-cs on node 2. I am able to use the admin credentials to perform
> operations on the bucket using s3cmd.
>
>  However, when I try to list riak-cs users using the riak-cs-control, I
> get no results. The error that comes up in /var/log/riak-cs.log is:
>
> 10.0.1.202 - - [09/Oct/2013:13:09:31 +0000] "GET /buckets/users/objects HTTP/1.1" 403 160 "" ""
>
>  I also receive a 403 when I try to create an admin user.
>
>  I saw https://github.com/basho/riak_cs_control/issues/31 and set my
> /etc/riak-cs-control/app.config file up to use the cs_proxy_host parameter
> as well, though I'm not using proxies, but to no avail. I have reproduced
> the relevant section of my riak-cs-control/app.config here:
>      {riak_cs_control, [
>        %% What port to run the application on.
>        {port, 8000 },
>
>         %% Instance of Riak CS you wish to talk to.
>        {cs_hostname, "10.0.1.202" },
>        {cs_port, 8080 },
>        {cs_protocol, "http" },
>
>         %% Proxy information; necessary if you are using s3.amazonaws.comas
>        %% your hostname.
>        {cs_proxy_host, "10.0.1.202" },
>        {cs_proxy_port, 8080 },
>
>         %% Credentials you want the application to run as.
>        {cs_admin_key, "5VI-NIFLNIHKRNGKPBVX" },
>        {cs_admin_secret, "xxxxxxx" },
>
>         %% Specify the bucket name for administration options.
>        {cs_administration_bucket, "riak-cs" }
>     ]},
>
>  Is there something I am missing/doing wrong?
>
>  Thanks,
>
>  Siddhu
>
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20131009/850b0a4b/attachment.html>


More information about the riak-users mailing list