Riak occasionally not storing objects

Brian Sparrow bsparrow at basho.com
Wed Oct 23 14:42:55 EDT 2013


In addition to Andrew’s question, what are the bucket properties for the bucket you are doing the writes against?  

Thanks,  

--  
Brian Sparrow
Developer Advocate
Basho Technologies

Sent with Sparrow (http://www.sparrowmailapp.com/?sig)


On Wednesday, October 23, 2013 at 2:40 PM, Andrew Thompson wrote:

> On Wed, Oct 23, 2013 at 02:36:11PM -0400, David Greenstein wrote:
> >  
> > Hello All,
> >  
> > I have a Riak cluster with 5 nodes on AWS m1.large instances, all using EBS deadline scheduling. The cluster is accessed via node.js and the riak-js library using the HTTP protocol. I’ve tried it with and without connection pooling. All software has been updated to the latest versions.
> >  
> > Occasionally, riak seems to not store an object I try to save. I have run tcpdump on the node receiving the request to ensure it is receiving the http packets with the correct JSON from the client. When the issue occurs the node is in fact receiving the request with the correct JSON.
> >  
> > Has anyone else experienced an issue like this? Any hints on how to debug the situation would be greatly appreciated.
>  
> What are your read and write quorums, and does the write report that it
> suceeded?
>  
> Andrew
>  
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com (mailto:riak-users at lists.basho.com)
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>  
>  


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20131023/00bb02e9/attachment.html>


More information about the riak-users mailing list