Version compatibility

Anton Khalikov anton at khalikov.ru
Sun Aug 3 13:57:59 EDT 2014


Hello Riak users and Basho guys

I've found an interesting page today: 
http://docs.basho.com/riakcs/latest/cookbooks/Version-Compatibility/ It 
says the latest working and recommended combination of Riak CS packages 
is: riak=1.4.10, stanchion=1.4.5 and riak-cs=1.5.0. Unfortunately I am 
unable to find stanchion=1.4.5 package for Debian Wheezy. Apt just gives 
me the following choices:

# apt-cache policy stanchion
stanchion:
   Installed: 1.4.3-1
   Candidate: 1.5.0-1
   Version table:
      1.5.0-1 0
         500 http://apt.basho.com/ wheezy/main amd64 Packages
  *** 1.4.3-1 0
         500 http://apt.basho.com/ wheezy/main amd64 Packages
         100 /var/lib/dpkg/status
      1.4.2-1 0
         500 http://apt.basho.com/ wheezy/main amd64 Packages
      1.4.1-1 0
         500 http://apt.basho.com/ wheezy/main amd64 Packages
      1.4.0-1 0
         500 http://apt.basho.com/ wheezy/main amd64 Packages

So I am not sure if I can upgrade to Riak CS 1.5.0 (we have 1.4.5 at the 
moment) and also should I upgrade Stanchion to 1.5.0 or leave 1.4.3 
version. Any suggestions?

-- 
Best regards
Anton Khalikov




More information about the riak-users mailing list