404 Error: Object Not Found

GTsui Gerry GTsui at edrnet.com
Thu Jan 2 09:22:07 EST 2014


A few things that you should check:
Try Riak ping
Check ./log/console.log for problem
ps aux ( is there a beam.smp running )

try change the listening ip to 127.0.0.1 and curl to 127.0.0.1

From: riak-users [mailto:riak-users-bounces at lists.basho.com] On Behalf Of Ari King
Sent: Wednesday, November 20, 2013 4:12 PM
To: riak-users at lists.basho.com
Subject: 404 Error: Object Not Found

I've installed a single node Riak cluster using the 5 minute install guide<http://docs.basho.com/riak/latest/quickstart/#Start-Up-Five-Nodes> and modified the app.config riak_core to include {target_n_val, 1} and {default_bucket_props, [{n_val, 1}]}. I've also set an IP address of 192.168.2.25, and set the HTTP port to 10018 respectively.
With this setup, no matter what HTTP request I execute, I receive the error below.

Does anyone know what I've done wrong?

* About to connect() to 192.168.2.25 port 10018 (#0)
*   Trying 192.168.2.25... connected
> PUT /riak/test/abc123?returnbody=true HTTP/1.1
> User-Agent: curl/7.22.0 (i686-pc-linux-gnu) libcurl/7.22.0 OpenSSL/1.0.1 zlib/                                                                                        1.2.3.4 libidn/1.23 librtmp/2.3
> Host: 192.168.2.25:10018<http://192.168.2.25:10018>
> Accept: */*
> Content-Type: application/json
> Content-Length: 47
>
* upload completely sent off: 47out of 47 bytes
< HTTP/1.1 404 Object Not Found
< Server: MochiWeb/1.1 WebMachine/1.10.0 (never breaks eye contact)
< Date: Wed, 20 Nov 2013 20:48:30 GMT
< Content-Type: text/html
< Content-Length: 193
<
* Connection #0 to host 192.168.2.25 left intact
* Closing connection #0
Thanks.
-Ari
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20140102/4b8d59f2/attachment.html>


More information about the riak-users mailing list