invalid hintfiles after upgrde

Jan Zahradka - MALL.cz jan.zahradka at mall.cz
Fri Jan 17 07:55:10 EST 2014


Hi everybody,

I have a 3 node Riak 1.1.1 cluster running on Centos 6.3. I wanted to 
upgrade it to the most recent version and I was told that first I have 
to upgrade to version 1.3.2 and then I can upgrade to 1.4.X version.

So I followed the instructions in Rolling upgrades guide (stop, upgrade 
package, start, status, wait-for-service riak_kv). After upgrading the 
package (1.1.1 -> 1.3.2) and starting new version I could see messages 
like this in console.log :

2014-01-17 12:58:31.638 [error] <0.658.0> Hintfile 
'/var/lib/riak/bitcask/707914855582156101004909840846949587645842325504/26.bitcask.hint' 
invalid
2014-01-17 12:58:31.974 [error] <0.662.0> Hintfile 
'/var/lib/riak/bitcask/981946412581700398168100746981252653831329677312/20.bitcask.hint' 
invalid
2014-01-17 12:58:32.043 [error] <0.661.0> Hintfile 
'/var/lib/riak/bitcask/890602560248518965780370444936484965102833893376/20.bitcask.hint' 
invalid
2014-01-17 12:58:32.064 [error] <0.663.0> Hintfile 
'/var/lib/riak/bitcask/1004782375664995756265033322492444576013453623296/22.bitcask.hint' 
invalid

etc etc.


I upgraded the whole cluster and it is functional. I read that hinfiles 
are not fatal for running, but I would like to have it clear.

Does anybody have any advice? Is it possible to rebuild the hintfiles? i 
tried to google it but no result ;o( (or maybe I'm not as googler as I 
thought ;o))


Thank You very much


Jan




More information about the riak-users mailing list