Node online and cannot run riak-admin test

Hector Castro hector at basho.com
Fri Jan 31 09:42:02 EST 2014


Hi Jose,

Did you ensure that you restarted the node after changing the Protocol
Buffers port to 9999? Your attempt to telnet attempt to the configured
PB port should succeed.

--
Hector


On Fri, Jan 31, 2014 at 4:48 AM, jose <josloe at gmail.com> wrote:
> i have create a 1 node at virtualbox with ubuntu 12.04 with 512mb ram, with
> bridge conection. i have installed riak 1.4.7 from source files. when i have
> installed run this commands to check health riak node:
> virtualbox machine ip: 192.168.0.200
> port pbc: 9999
>
> @ubuntu:~$ riak-admin test
> Failed to read test value: {error,{insufficient_vnodes,0,need,1}}
>
>
> -------
> app.config
> {pb_ip, [ {"192.168.0.200", 9999 } ]}
>  {http, [ {"192.168.0.200", 8098 } ]},
>
> ---------
>
> -------------------
> ubuntu at ubuntu:~$ riak-admin member_status
> ================================= Membership
> ==================================
> Status     Ring    Pending    Node
> -------------------------------------------------------------------------------
> valid     100.0%      --      'riak at 192.168.0.200'
> -------------------------------------------------------------------------------
> Valid:1 / Leaving:0 / Exiting:0 / Joining:0 / Down:0
> ------------------
>
> ubuntu at ubuntu:~$ riak-admin ring_status
> ================================== Claimant
> ===================================
> Claimant:  'riak at 192.168.0.200'
> Status:     up
> Ring Ready: true
>
> ============================== Ownership Handoff
> ==============================
> No pending changes.
>
> ============================== Unreachable Nodes
> ==============================
> All nodes are up and reachable
> ---------------------
>
> --------
> ubuntu at ubuntu:~$ telnet 192.168.0.200 9999
> Trying 192.168.0.200...
> telnet: Unable to connect to remote host: Connection refused
> ----------
>
> ubuntu at ubuntu:~$ telnet 192.168.0.200 8098
> Trying 192.168.0.200...
> Connected to 192.168.0.200.
> Escape character is '^]'.
> -------------------
>
> ubuntu at ubuntu:~$ riak ping
> pong
> -------
>
>
>
> ----------
> ubuntu at ubuntu:~$ curl -v http://192.168.0.200:8098/riak/test
> * About to connect() to 192.168.0.200 port 8098 (#0)
> *   Trying 192.168.0.200... connected
>> GET /riak/test HTTP/1.1
>> User-Agent: curl/7.22.0 (i686-pc-linux-gnu) libcurl/7.22.0 OpenSSL/1.0.1
>> zlib/1.2.3.4 libidn/1.23 librtmp/2.3
>> Host: 192.168.0.200:8098
>> Accept: */*
>>
> < HTTP/1.1 200 OK
> < Vary: Accept-Encoding
> < Server: MochiWeb/1.1 WebMachine/1.10.0 (never breaks eye contact)
> < Date: Fri, 31 Jan 2014 09:22:19 GMT
> < Content-Type: application/json
> < Content-Length: 422
> <
> * Connection #0 to host 192.168.0.200 left intact
> * Closing connection #0
> {"props":{"name":"test","allow_mult":false,"basic_quorum":false,"big_vclock":50,"chash_keyfun":{"mod":"riak_core_util","fun":"chash_std_keyfun"},"dw":"quorum","last_write_wins":false,"linkfun":{"mod":"riak_kv_wm_link_walker","fun":"mapreduce_linkfun"},"n_val":3,"notfound_ok":true,"old_vclock":86400,"postcommit":[],"pr":0,"precommit":[],"pw":0,"r":"quorum","rw":"quorum","small_vclock":50,"w":"quorum","young_vclock":20}}ubuntu at ubuntu:~$
> -----
>
>
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>




More information about the riak-users mailing list