Python 2.6 support?

Naveen Tamanam naveen32india at gmail.com
Thu Jul 10 07:16:33 EDT 2014


Brett,

My whole code was written for  python-client 1.5.x .  If I use
python-client 2.0.x  it causes problem as there are api changes in 2.0 .
Can I get  fix for httplib.BadStatusLine for  python-client 1.5.x .  will
we get next python-client 1.5.x  release?
What do you suggest, my production uses python-client 1.5.x .


On Thu, Jul 10, 2014 at 3:59 PM, Brett Hazen <brett at basho.com> wrote:

> Naveen —
>
> Yes.  The suggested Python version is 2.7, but I just tried it on
> riak-1.4.8 and Python 2.6.6 and it seemed to work.
>
> Brett
>
> On July 10, 2014 at 11:25:43 AM, Naveen Tamanam (naveen32india at gmail.com)
> wrote:
>
>  Hi Brett,
>
> Do you mean, I can use  riak-python-client 2.0.3 with  riak-1.4.7
>
>
> On Thu, Jul 10, 2014 at 3:41 PM, Brett Hazen <brett at basho.com> wrote:
>
>>  Naveen -
>>
>> The current *master* branch on the riak-python-client repo targets Riak
>> 2.0, not Riak 1.4.x any more.
>>
>> The latest released client is 2.0.3 (not be be confused with Riak 2.0)
>> which is available on PyPI https://pypi.python.org/pypi/riak/2.0.3 or on
>> GitHub with tag “2.0.3”
>> https://github.com/basho/riak-python-client/releases/tag/2.0.3.  This
>> has the BadStatusLine fix already in it.
>>
>> Brett
>>
>> On July 10, 2014 at 9:14:08 AM, Naveen Tamanam (naveen at lintelindia.com)
>> wrote:
>>
>>   Hi Sean,
>>
>> I am also the person who is using  riak client on production with python
>> 2.6.x.
>>
>> On one  of our testing environment we have  python 2.6.6, riak-1.4.7  and
>> python client  riak-1.5.1-py2.6.
>> There frequently I am getting  httplib.BadStatusLine causing  RiakError:
>> 'could not get a response'
>>  after 3 retries. I found the fix
>> https://github.com/basho/riak-python-client/pull/210.
>>  That fix got merged into master branch, Can I use master branch with
>> riak-1.4.7
>>
>>
>> On Thu, Jun 26, 2014 at 12:39 AM, Sean Cribbs <sean at basho.com> wrote:
>>
>>> In the process of developing the Python client for 2.0 features, we're
>>> running into issues with Python 2.6.x (specifically related to pyOpenSSL
>>> and its dependencies). Is anyone out there using Python 2.6 in production
>>> still and wanting to use the Riak client?
>>>
>>> --
>>> Sean Cribbs <sean at basho.com>
>>> Software Engineer
>>> Basho Technologies, Inc.
>>> http://basho.com/
>>>
>>> _______________________________________________
>>> riak-users mailing list
>>> riak-users at lists.basho.com
>>> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>>>
>>>
>>
>>
>> --
>> Thanks & Regards,
>> Naveen Tamanam
>>  _______________________________________________
>> riak-users mailing list
>> riak-users at lists.basho.com
>> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>>
>>
>> _______________________________________________
>> riak-users mailing list
>> riak-users at lists.basho.com
>> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>>
>>
>
>
> --
> Thanks & Regards,
> Naveen Tamanam
>
>


-- 
Thanks & Regards,
Naveen Tamanam
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20140710/8a86b813/attachment.html>


More information about the riak-users mailing list