SSL Configuration for Riak-CS

Luke Bakken lbakken at basho.com
Thu Jul 10 12:04:07 EDT 2014


Hi Igor -

Did you configure SSL certificates as instructed here?

http://docs.basho.com/riakcs/latest/cookbooks/configuration/Configuring-Riak-CS/#Enabling-SSL-in-Riak-CS

Also, since it's best practice to load-balance connections to your
Riak CS nodes, I would recommend enabling SSL on a load balancer like
haproxy, and then use HTTP for connections from haproxy to Riak CS.
--
Luke Bakken
CSE
lbakken at basho.com


On Wed, Jul 2, 2014 at 1:10 PM, Igor Birman <igor_birman at yahoo.com> wrote:
> Hi,
>
> I am struggling getting SSL working with Riak-CS.  I can add SSL settings to
> the config, but s3cmd does not let me connect using a proxy.  If I turn off
> the proxy configuration and add s3.amazonaws.com to my hosts file, it tries
> to access Riak-CS over port 443.  I tried connecting using S3 Browser with a
> proxy, but I get some interesting errors in Riak-CS:
>
> 15:59:11.071 [error] CRASH REPORT Process <0.9237.0> with 0 neighbours
> crashed with reason: no function clause matching
> mochiweb:new_request({#Port<0.3360>,{"CONNECT",{scheme,"s3.amazonaws.com","443"},{1,1}},[{'Proxy-Connection',"Keep-A..."},...]})
> line 51
>
> I have Riak-CS running on port 8080, so I am not sure where the 443 is
> coming from.
>
> Has anyone gotten Riak-CS to work with SSL?
>
> Thanks,
> Igor
>
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>




More information about the riak-users mailing list