ring_creation_size with `riak-admin status`

Sean Cribbs sean at basho.com
Mon Jul 21 10:19:24 EDT 2014


Matthew,

At least one or more of your nodes must have started before you changed
that setting. Debian pretty often will start a service immediately after
its package is installed, which can be annoying. Assuming you didn't put
any data in it yet, the solution is to take all of the nodes down, remove
all files from /var/lib/riak/ring on all nodes, and then restart and rejoin
the cluster.


On Mon, Jul 21, 2014 at 8:48 AM, Matthew Eernisse <mde at fleegix.org> wrote:

> Riak folks,
>
> Hi, I'm new to Riak, and confused by something I've seen after setting up
> a cluster. (Currently a 4-machine test cluster in EC2.)
>
> After installing Riak on Ubuntu via the riak_1.4.9-1_amd64.deb, I very
> meticulously set ring_creation_size to 256 in each app.config before
> starting the service and adding it to the cluster.
>
> But when I do `riak-admin status`, it displays a ring_creation_size value
> of 64. Any idea what's going on here?
>
> Thanks in advance for the help.
>
>
> Matthew
>
> _______________________________________________
> riak-users mailing list
> riak-users at lists.basho.com
> http://lists.basho.com/mailman/listinfo/riak-users_lists.basho.com
>
>


-- 
Sean Cribbs <sean at basho.com>
Software Engineer
Basho Technologies, Inc.
http://basho.com/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20140721/95d51c83/attachment.html>


More information about the riak-users mailing list