Issues with high node load and very slow response

Jordan West jwest at basho.com
Mon Jul 28 11:51:18 EDT 2014


adding the list back


On Mon, Jul 28, 2014 at 8:50 AM, Jordan West <jwest at basho.com> wrote:

> On Mon, Jul 28, 2014 at 7:43 AM, Chaim Solomon <chaim at itcentralstation.com
> > wrote:
>>
>> I'm getting lots of these still:
>> 2014-07-28 10:40:52.915 [info] <0.822.0>@yz_kv:should_handoff:157 waiting
>> for bucket types prefix and indexes to agree between 'riak at 10.128.179.86'
>> and 'riak at 10.128.220.242'
>> 2014-07-28 10:41:22.527 [info] <0.30017.425>@yz_kv:should_handoff:157
>> waiting for bucket types prefix and indexes to agree between '
>> riak at 10.128.179.86' and 'riak at 10.128.220.242'
>>
>
> Unfortunately, there is more than one case that can cause this message to
> occur. Can you try one more command (from any node in the cluster):
>
> ```
> rpc:multicall([node() | nodes()], yz_solr, cores, [], 5000).
> ```
>
> I'm working on a patch to improve the logging here (so running these
> commands won't be necessary) but that may take a bit to get reviewed.
>
>
>> Only one node (10.128.220.135) is giving me this:
>> 2014-07-28 10:31:31.618 [error] <0.847.706>@yz_kv:index:206 failed to
>> index object {<<"linkmeta">>,<<"http://scn.sap.com/thread/3262664">>}
>> with error {"Failed to index docs",{error,req_timedout}} because
>> [{yz_solr,index,3,[{file,"src/yz_solr.erl"},{line,192}]},{yz_kv,index,7,[{file,"src/yz_kv.erl"},{line,258}]},{yz_kv,index,3,[{file,"src/yz_kv.erl"},{line,193}]},{riak_kv_vnode,actual_put,6,[{file,"src/riak_kv_vnode.erl"},{line,1416}]},{riak_kv_vnode,perform_put,3,[{file,"src/riak_kv_vnode.erl"},{line,1404}]},{riak_kv_vnode,do_put,7,[{file,"src/riak_kv_vnode.erl"},{line,1199}]},{riak_kv_vnode,handle_command,3,[{file,"src/riak_kv_vnode.erl"},{line,485}]},{riak_core_vnode,vnode_command,3,[{file,"src/riak_core_vnode.erl"},{line,345}]}]
>>
>>
> My suspicion is the command above will shed some light on the error here.
>
> Also, so we don't leave behind the main issue of CPU usage, is this node
> one of the two having problems? Which is the other?
>
> Thanks!
> Jordan
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.basho.com/pipermail/riak-users_lists.basho.com/attachments/20140728/448dec46/attachment.html>


More information about the riak-users mailing list